Sakhr AX-370 and OSSC

By Maltarouti2

Rookie (20)

Аватар пользователя Maltarouti2

08-04-2021, 14:40

I have a problem using the Kaico OSSC with my MSX, which is a Sakhr AX-370. The screen displays black and blue only. I am connecting the MSX to the OSSC using RGB cable to Scart port.
I am using the following cable
MSX scart cable
The OSSC seems to properly recognize the signal.
https://www.dropbox.com/s/d2ssezghoaggnzt/Screenshot_20210408_153332.jpg?dl=0
I tried two different TVs both have the same issue
https://www.dropbox.com/s/wwqxn0ik0mrcexo/Screenshot_20210408_153356.jpg?dl=0
Any tips ?

Для того, чтобы оставить комментарий, необходимо регистрация или !login

By Grauw

Ascended (10167)

Аватар пользователя Grauw

08-04-2021, 14:50

Have you tried switching to 60 Hz?

Type VDP(10)=0 in MSX-BASIC.

By sdsnatcher73

Prophet (2349)

Аватар пользователя sdsnatcher73

08-04-2021, 18:56

Personally I created my own profile using the profile editor located here. On that site you can export this (in combination with some other profiles) to a binary blob that the OSCC can import settings from. I have a DELL P1914S LCD with 1280x1024 resolution and I get perfect image in both 50Hz and 60Hz.

By wbahnassi

Master (147)

Аватар пользователя wbahnassi

08-04-2021, 19:05

Double check your lines, probably you have a disconnection or the lines are mapped incorrectly between the SCART and the 8-pin DIN. This means the cable is maybe damaged, because I have that exact cable and it works fine from that seller. I also built my own cable successfully with the AX370 and OSSC.

By Maltarouti2

Rookie (20)

Аватар пользователя Maltarouti2

08-04-2021, 19:28

Thank you all for your input. It turns out the fault is with RGB port on the MSX machine. I tried the same setup with another AX-370 and it's working fine with proper colors and sound (including the familar constant hissing sound )

By Grauw

Ascended (10167)

Аватар пользователя Grauw

08-04-2021, 19:37

You can try to resolder the joints of the socket. If you’re lucky they’re just cracked from use and no longer making a good connection. In such cases typically jiggling the connector will also make the image flicker.

By Maltarouti2

Rookie (20)

Аватар пользователя Maltarouti2

08-04-2021, 20:48

The socket is not wobbly or anything but I hope it's that simple.
Will give it a try. Thanks Smile

By Maltarouti2

Rookie (20)

Аватар пользователя Maltarouti2

11-04-2021, 19:31

Unrelated to the RGB socket issue but is there a way to stay in 60hz mode after turning off or resetting the MSX? Right now it reverts back to 50hz after reset

By Maltarouti2

Rookie (20)

Аватар пользователя Maltarouti2

11-04-2021, 19:33

The socket is properly soldered to the PCB. Could it be the socket itself is damaged? And where can I find a replacement part?

By Grauw

Ascended (10167)

Аватар пользователя Grauw

11-04-2021, 20:26

Maltarouti2 wrote:

Unrelated to the RGB socket issue but is there a way to stay in 60hz mode after turning off or resetting the MSX? Right now it reverts back to 50hz after reset

Only by modifying and replacing the BIOS ROM chip.