SX-1+ Mini with MegaFlashRom SCC+ SD problem(s)

Страница 3/9
1 | 2 | | 4 | 5 | 6 | 7 | 8

By SjaaQ

Master (203)

Аватар пользователя SjaaQ

12-10-2020, 08:58

SkalTura wrote:

The MFR works fine in my Sony, so I doubt that there is a problem with this.

I meant the keyboard issue.

SkalTura wrote:

I converted the game to a ROM to load in the MFR, and it works on the Sony...

Just tried this using OPFXSD DIX.DSK /ID . I will just assume this is what you mean with "converted the game".

Works on my NMS8280, does not on the SX1. Interesting. I'm going to see if I can find the issue.

By Guillian

Prophet (3411)

Аватар пользователя Guillian

12-10-2020, 09:18

SjaaQ wrote:

Just tried this using OPFXSD DIX.DSK /ID . I will just assume this is what you mean with "converted the game".

Bear in mind that /ID option is for installing a ROM Disk (built in drive A: )
For flashing a DSK as a ROM you should use /Dx option. E.g.: OPFXSD DIX.DSK /D1

By SjaaQ

Master (203)

Аватар пользователя SjaaQ

12-10-2020, 11:40

I have found that DIX puts ram on page 4000 in the boot sector using the variable at F342. When you do not have DOS2 enabled this value is randomly set (it was 151 at my SX1). If the MFR does not initialize the DISK rom correctly and the value is still some random value it will probably crash due to that.

I'll have to do some more debugging to see if this is the actual cause.

By SkalTura

Champion (315)

Аватар пользователя SkalTura

12-10-2020, 17:14

SjaaQ wrote:

Just tried this using OPFXSD DIX.DSK /ID . I will just assume this is what you mean with "converted the game"

No... I used DSK2ROM to convert it to a ROM file, and loaded this into the MultiBoot together with some other games.

By SjaaQ

Master (203)

Аватар пользователя SjaaQ

12-10-2020, 19:13

I don't think it matters in this case. Does not work with my instruction as well.

By SkalTura

Champion (315)

Аватар пользователя SkalTura

14-10-2020, 17:26

Borrowed a (HP) keyboard from a friend, and that works fine.
So my Cherry keyboard doesn't work with the SX-1 apparently...

By SjaaQ

Master (203)

Аватар пользователя SjaaQ

15-10-2020, 07:43

I was planning to buy a new mechanical keyboard to pair up with the SX1. I found that most of the newer keyboards do not actually do support PS/2 using a USB-PS/2 converter plug. I ended up buying the Leopold FC750R because the manufacturer specified it was PS/2 compatible and it came with a converter plug. This keyboard works flawlessly on the SX1.

Maybe the Cherry you have draws too much power. Maybe it is not 100% compatible. Who will tell?

Have you contacted 8bit4ever about the MFR issue yet?

By SkalTura

Champion (315)

Аватар пользователя SkalTura

15-10-2020, 10:49

I reloaded the MULTIROM.OPF to see what type of ROM's the games are, and found that all the games that are not working (or not working properly) are all "ASCII 8K" ROM's.
But there are also ASCII 8K games that are working fine, so not sure why that is.

But apart from this, the main problem I still have it that I need to reset (sometimes upto 10 times) before the MFR is detected. Very annoying...
I will contact the guys at 8Bits4Ever about this, see what they have to say about this.

By SkalTura

Champion (315)

Аватар пользователя SkalTura

15-10-2020, 15:05

Just got a reply from the 8Bits4Ever team...
They think it could be a bad RAM/FPGA, or poor soldering, that causes timing issues.

I did some more tests, and found that when I insert 2 cartridges (for example the MFR in slot 1, and my Stereo FM-Pak in slot 2) that the failure to start happens a lot less. It still happens..., but not as often as when the MFR is the only cartridge inserted.
So I think they are right that it is indeed a hardware problem with my specific SX-1

I will return it for a full hardware check.
...Sad face...

By SjaaQ

Master (203)

Аватар пользователя SjaaQ

15-10-2020, 21:27

Well its no fun to have to return it, but at least it is not your fault. Or a usage error.

Страница 3/9
1 | 2 | | 4 | 5 | 6 | 7 | 8