two different MSX2s, two different FM Audio cartridges, two different games, same result

Страница 1/2
| 2

By Cooljerk

Rookie (26)

Аватар пользователя Cooljerk

16-06-2020, 07:39

I'm stumped as to what is causing my headaches with the FM Pac across multiple MSX2s and games. Seemingly without rhyme or reason, my FM PAC carts won't produce audio, completely at random. I have two games I'm testing with, Aleste and R-Type, and on each cartridge, out of maybe 30 boots, 5 or so will have appropriate FM audio, with the remaining 25 only producing PSG sound effects.

My first thought was perhaps my MSX2 was on the fritz, it needs to be recapped as the normal PSG audio is very low. it's a sony Hitbit F1-II, so I thought maybe the line connecting the FM cart to the audio out port is busted or something. I picked up a Panasonic FS-A1 II, but it exhibited the same problem.

Next, I thought maybe my FM cart was going out, it was an original Panamusement FM Pac which is pretty old, so I picked up a new FM-PAK from 8-bits-forever. This cartridge has a line out port so I can bypass the audio from the MSX output entirely and just listen to the cart itself. Just like before, same deal, no audio coming out of the FM cart.

This happens on both MSXs, on both cartridge, with both games. Sometimes I'll boot the machines and the FM cart will just work without any fuss, but the vast majority of times it takes like 30 minutes of fiddling with the connections to get going before the FM audio kicks in.

This is happening on multiple audio output devices (TV, external speakers, headphones), as well, using multiple AV cables, so I'm stumped as to what could be the problem here. The FM-Pak is brand new, I got it maybe 2 hours ago in the mail, so I'm fairly certain it's not faulty.

Any ideas on how I could further trouble shoot or ideas on what I could try?

Для того, чтобы оставить комментарий, необходимо регистрация или !login

By Rataplan

Master (227)

Аватар пользователя Rataplan

16-06-2020, 07:54

Do other cartridges work in the same slot? Or is it just the FM pacs that don't work propely?

By Cooljerk

Rookie (26)

Аватар пользователя Cooljerk

16-06-2020, 08:13

Yeah, I tested both slots to make sure they are being read correctly. The Konami game master carts or various game combinations work like Penguin Adventure and Gradius, for example. I've also tried swapping the order of the carts -- it seems like when it does produce FM audio, it tends to be when the FM cart is in the primary slot with the game in the secondary slot. Dunno if that matters much.

I have a megaflashrom SD+ coming in the mail soon enough, so when it arrives I can try the same FM audio games on the flashrom. My only guess would be that, somehow, both Aleste and R-Type carts are messed up in the same way, but that seems like a pretty big stretch.

I'm honestly stumped.

Just to further clarify the symptoms:

-The games always boot up, regardless of the cartridge slot used. In both cartridge slots, the games boot, either with or without FM cart.

-When they boot with an FM cart inserted, the vast majority of the time there is no music at all, the only output being the PSG sound effects in games (like the shots in R-Type). This tells me A) The game can detect the FM cart enough to know to disable PSG music, and B) it's like the FM Cart itself never is started

-No audio output from the FM cart directly through the built-in line port, so it's not just that the audio isn't reaching the mono port on the MSX, it's like the FM Cart itself isn't turned on or something. But, despite that, the game itself knows it's inserted and adjusts accordingly.

By gdx

Prophet (3571)

Аватар пользователя gdx

16-06-2020, 09:34

The original FM-PAC has a switch to set the sound volume low/medium/high.
Since the volume can vary from one MSX to another, the sound extensions should have a volume regulator but nobody does it to make economies.

Either you buy an original FM-PAC or you modify the sound output of your cartridges.

By Cooljerk

Rookie (26)

Аватар пользователя Cooljerk

16-06-2020, 09:39

I have an original Panamusement FM-PAC, the switch doesn't make a difference unfortunately. It's not that the audio is coming out quietly, it's not coming out at all. With my Sony HB-F1 II, since it needs recapping, I already crank the audio on the speakers up as loud as they can go. I can hear the PSG sound effects just fine, there is simply no FM audio behind it at all. And, on the occasions that the FM Audio does play, it plays at the appropriate sound level. That's why I'm so stumped.

This lack of audio happens on both the original FM-PAC and the newer FM-PAK with line out.

By Jipe

Paragon (1390)

Аватар пользователя Jipe

16-06-2020, 09:50

see this post for testing your Panamusement FM-PAC
https://www.msx.org/forum/msx-talk/hardware/testing-fm-pac

By Cooljerk

Rookie (26)

Аватар пользователя Cooljerk

16-06-2020, 10:06

Jipe wrote:

see this post for testing your Panamusement FM-PAC
https://www.msx.org/forum/msx-talk/hardware/testing-fm-pac

Thanks for this. Just making sure I'm doing this correctly, the command in the original FM-PAC to play BGM music is space bar, right? If so, then it appears it's not playing audio in the BIOS menu either, on either machine.

By Pentarou

Champion (266)

Аватар пользователя Pentarou

16-06-2020, 10:36

There could be a problem with the +12/-12 voltage.
The Wiki has a picture of the FS-A1mkII & HB-F1 power adapter which look very similar, are you sharing the same PSU on both machines?

By Cooljerk

Rookie (26)

Аватар пользователя Cooljerk

16-06-2020, 11:10

no, that was an original concern of mine as well. I use the provided FS-A1mkII PSU with the panasonic machine, and the HB-F1 PSU with the sony one. The bricks say they match volts and amps, but I'm always paranoid about the details.

Within the last few moments, the sony machine has seemingly started reliably playing FM music with both the original FMPAC and the new FM-PAK. The panasonic machine still only very infrequently provides output. Using the topic posts above, i can induce a tone using BASIC, it plays back reliably on my hitbit but is silent on my panasonic.

One thing very odd to note, the line-out of the FM PAK I'm using, I can hear the PSG output through it on the panasonic machine. According to the site I bought it from, it should only output FM, no mix. So it's like the audio mixing pin of the cartridge slot is going backwards or something, I'm very confused.

By DarkSchneider

Paladin (932)

Аватар пользователя DarkSchneider

16-06-2020, 11:14

Maybe the FM-PAC degrades over time? Not sure if it is easy to open to check inside.

By osises

Master (230)

Аватар пользователя osises

16-06-2020, 11:14

Hi. For this explanation, it seems that this is a power problem.

The FM cartridge consumes more current than the equipment can presumably deliver through the connector. Out of capacitors? On the MSX and / or the FM cartridge? Bad power supply?

You should check these points to be sure what is going wrong.

Good luck

Страница 1/2
| 2