проблема с железом YIS503

Страница 1/6
| 2 | 3 | 4 | 5 | 6

By alex_integral

Supporter (6)

Аватар пользователя alex_integral

22-04-2010, 09:24

первый раз включается хорошо. при перезагрузках часто зависает после заставки с информацией о памяти, когда должно появиться 4 строки текста типа "Classroom ... No ... OK". вместо строк - пустой экран и отсутствие реакции на раздражители. внешнее оборудование отсутствует, ямаха стандартная.
подскажите, кто виноват? ПЗУ дохнет?

Для того, чтобы оставить комментарий, необходимо регистрация или !login

By cax

Prophet (3737)

Аватар пользователя cax

22-04-2010, 09:42

Начни с того, что вытащи батарейки микросхемы часов, выдерни вилку из электросети, и включи кнопку питания.
Далее попробуй открутить и вытащить сетевой блок (полагаю, он тебе в работе не нужен, а зависаний разных от него бывает много)
Расскажи как машина ведёт себя после этого.

By alex_integral

Supporter (6)

Аватар пользователя alex_integral

22-04-2010, 11:56

сеть нужна (msxlink to RS232). остальное попробую, скажу.

By Eugeny_Brychkov

Paragon (1184)

Аватар пользователя Eugeny_Brychkov

22-04-2010, 14:57

Регулярно наблюдаю такой глюк, правда только на 805, и только после игруханья. Я лечу глобальным выключением железки на минут 10. Рут коз мне неизвестен.

By msxegor

Master (183)

Аватар пользователя msxegor

22-04-2010, 15:46

Да причина-то тривиальна - слишком качественная память, помнит то, что должна бы забыть. А всего-то нужно 'AB' по адресу 4000h.

By cax

Prophet (3737)

Аватар пользователя cax

22-04-2010, 16:03

Зависания после игр как раз должны случаться постоянно и у всех, т.к. во многих играх сигнатура "AB" по адресу 0х4000 остаётся в памяти, и воспринимается машиной как вставленный картридж, но далеко не все из них способны перезапуститься и либо виснут либо ведут себя другим непредсказуемым способом.
Память стирается не всегда даже при выключении питания, иногда даже через 10-15 секунд.

By neznajka

Champion (306)

Аватар пользователя neznajka

14-06-2019, 18:38

Тема с подходящим названием поэтому решил написать сюда.
Вообщем при помощи паяльника, ручного отсоса и под конец уже фена выковырял пзу с платы YIS503IIR. Восстановил дорожку от видеочипа. Паяльник ясное дело не заземлен. В панельки запихнул w27c512 с прошивками от кувт2 без часов.
При включении щелкает релюшка, на экране ничего и горит капс на клавиатуре. Естественно не реагирует на внешние раздражители. С старой ПЗУ такой же результат. Процессор немного тепленький.
Теперь возник вопрос к знающим. Что наиболее вероятно померло? Процессор или видеочип ? Там правда еще рядом с пзу была s3527.

By АIеks

Paladin (949)

Аватар пользователя АIеks

14-06-2019, 19:41

Если капс загорается и реле щелкает, то, как минимум ЦПУ видимо рабочий. Но что-то идет не так. Посмотрите внимательно, может переходное отверстие порвали или сопля где.

И я вот не уверен можно вот так просто заменить старую ПЗУ на w27c512.

Главное на долго не включайте попробовали и быстро выключили.

Без ПЗУ капс горит и реле щелкает?

Да и не вздумайте паяльник заземлять, слишком много нюансов появляется после заземления. Если паяльник исправный и раньше с ним проблем не было, то все будет ок.

By neznajka

Champion (306)

Аватар пользователя neznajka

14-06-2019, 20:26

АIеks wrote:

Без ПЗУ капс горит и реле щелкает?

Без ПЗУ все также горит и щелкает. Сейчас еще раз перепроверю

Плата на просвет двухслойная. Явно выдранных дорожек не наблюдал.
На 30пиновой панельке под ром на 21ой ноге похоже сделал соединение с 23 и 25ой которые выходят на пятак возле надписи ROMCS. Попробую убрать и запустить с старым ромом

После того как убрал образовавшийся контакт все завелось. Со старым пзу выдало нормальную картинку. С винбондами тоже завелось но не так как нужно. На экране все выглядит так

При этом видно как текст набирается в виде точек на экране.

Спасибо АIеks я уже думал что улучшил мсх до лома на драгметалы.

By АIеks

Paladin (949)

Аватар пользователя АIеks

14-06-2019, 20:49

neznajka wrote:

При включении щелкает релюшка, на экране ничего и горит капс на клавиатуре.

А что было? A, понял - сделал соединение с 23 и 25ой. Короткнули адресную линию А11 и А8.

Судя по картинке неправильно инициализируется VDU. Кстати если вы поставили модифицированную прошивку кувт2, то там еще нужен саб-ром (второе ПЗУ). Вроде так, подробности надо освежить в памяти.

By neznajka

Champion (306)

Аватар пользователя neznajka

14-06-2019, 20:57

АIеks wrote:
neznajka wrote:

При включении щелкает релюшка, на экране ничего и горит капс на клавиатуре.

А что было?

Судя по картинке неправильно инициализируется VDU. Кстати если вы поставили модифицированную прошивку кувт2, то там еще нужен саб-ром (второе ПЗУ). Вроде так, подробности надо освежить в памяти.

возле 21ой ноги микросхемы памяти проходила дорожка и видать когда там паяльником ковырял ободрал маску. С пятака припой зацепился за дорожку. И выходит что пзу работало не верно.

Поставил обе. Второе пзу с патчем который нашел на zx-pk и ром тоже там взял с исправленными шрифтам.

Возможно проблема в подключении дополнительного рома. 512КБ вместо 128 подсунул. возможно ногу какуюто нужно на землю подсоеденить. А еще я не установил микросхемы на мапер памяти. Может это тоже повлияло ?

Страница 1/6
| 2 | 3 | 4 | 5 | 6