Problem using Chimera on MacOSX

Página 1/2
| 2

Por jalu

Master (158)

imagem de jalu

17-02-2003, 18:39

I have a hard time typing this message, since the text-enter box in Chimera (MacOSX) shows a white letter on a white background… Chimera btw is a gecko based browser. All other parts of the site and forum look just fine…

Entrar ou registrar-se para comentar

Por Latok

msx guru (3836)

imagem de Latok

17-02-2003, 19:02

Jalu, you are a brave warrior starting such a thread about MacOSX! But erhm......What's your point here?

Por Grauw

Ascended (10079)

imagem de Grauw

17-02-2003, 19:18

It seems Chimera doesn't offer full CSS support yet ^_^.

My opinion on this: if you want your page to exceed the most Basic HTML functionality, you can't let everything work on every browser. There are too many browsers to test them all, and there's still too much lack of standards-compliance amongst them (and therefore it's not a feasible task to write workarounds for all of them, nor does it encourage the developers to improve their browser). Unless, ofcourse, you can point out that it's the msx.org code's fault ^_^.

ps. Now that I'm looking at the html code of this forum edit page, I can see all kinds of Javascript like if (action == "url") { var thisURL = prompt("Enter the URL for the link you want to add.", "http://");, etc. Heh, what's the deal here? Are you going to add buttons for those scripts or what? ;p

~Grauw

Por anonymous

incognito ergo sum (116)

imagem de anonymous

17-02-2003, 22:02

Chimera a gecko based browser? Must be a REALLY old version then, because using Mozilla (also gecko based) there are no problems.

Por snout

Ascended (15184)

imagem de snout

17-02-2003, 22:31

Grauw - we are not going to add buttons, we removed them. But nut (all) sourcecode. Still working on cleaning up. And indeed.. if the browser does not support CSS the right way, well then you're just unlucky I'm afraid Sad

Por jalu

Master (158)

imagem de jalu

18-02-2003, 08:39

Jalu, you are a brave warrior starting such a thread about MacOSX! But erhm......What's your point here?

Ehm..well if I'm in the wrong forum, I apologise Smile Didn't know where to go...

About Chimera: (www.mozilla.org/projects/chimera/) Strangely, it shows the entire MSX.org site perfectly, only when entering text in the forum, the background color of the textbox is not set to blue, but remains white. And indeed, I can confirm that Mozilla on OSX indeed shows the correct layout. I don't know whether or not this is a bug in Chimera, just thought I'd let you know. :)

Por Latok

msx guru (3836)

imagem de Latok

18-02-2003, 09:53

Jalu - Nops, my fault.....I should have read better.....My apologies Wink

Por Grauw

Ascended (10079)

imagem de Grauw

18-02-2003, 15:47

Maybe you can take a look at the css used for coloring the edit box its background (provided you know a little about css I guess ^_^ www.w3.org eh), or maybe one of the msx.org members can do this, just to verify whether it's correct and not 'IE' code or something (which Mozilla often understands aswell), and if the css is indeed correct, submit it as a bug to the Chimera developers?

~Grauw

Por anonymous

incognito ergo sum (116)

imagem de anonymous

18-02-2003, 17:51

Grauw, Mozilla and Chimera both use the same rendering engine, Gecko. And AFAIK Gecko does not support IE 'extensions' or whatever crap micro$oft built in. Anyway... There must be something wrong with Chimera, maybe it's an older version, maybe a 'user stylesheet' is overriding msx.org's, it could be several things...

Por snout

Ascended (15184)

imagem de snout

22-02-2003, 00:30

Please let us know if you found out what's causing the trouble!

Por msxgamesbox

Champion (397)

imagem de msxgamesbox

22-02-2003, 14:17

Testing Chimera and indeed I'm writing white on white.... argh!

Página 1/2
| 2