MSX-Link

Página 2/5
1 | | 3 | 4 | 5

Por Eugeny_Brychkov

Paragon (1166)

imagem de Eugeny_Brychkov

27-11-2009, 23:00

mode COM1 baud=38400 parity=n?

http://msxlink.chat.ru/

Hyperterminal может не только принимать, но также и передавать... поиграйся с разными установками. Типа в нем нажимаешь клавишу, и соотв символ должен высветиться на MSX.

Мож какая-н микросхема померла? Или что-то с сетевым блоком MSX? Кстати, в нем есть переключатели. Вполне возможно, надо выставить какое-н значение. На страничке написано что значение не должно быть равно 0 (не учительская). Может заработает?

Por vladimir32

Supporter (16)

imagem de vladimir32

28-11-2009, 03:32

А он точно заработает на MSX2 ? Кто-нибудь проверял ?

Я не пробовал. Т.е. если vladimir32 согласиться на обмен, то, разумеется, за дым из компьютера я ответственности не несу Smile
Могу лишь точно сказать, что с YIS503II работал прекрасно.

Да соглашусь конечно, только ты чего-то на аську не отвечаешь. Попробуй меня добавить - 35611512. А синтезатор я давно достал, подключил и проверил.

Por AlexBel

Champion (268)

imagem de AlexBel

28-11-2009, 07:56

Да соглашусь конечно, только ты чего-то на аську не отвечаешь. Попробуй меня добавить - 35611512. А синтезатор я давно достал, подключил и проверил.

Добавил, запросил авторизацию.

А аська у меня в будни работает почти все время с 9 до 18 часов по москве, по вечерам и в выходные - как получится, ни сообщений, ни запросов авторизации не видел. Возможно, сервак аськи глючит. Сейчас перепроверил - аська указана правильно.

Por AlexBel

Champion (268)

imagem de AlexBel

28-11-2009, 08:00

mode COM1 baud=38400 parity=n?

http://msxlink.chat.ru/

Hyperterminal может не только принимать, но также и передавать... поиграйся с разными установками. Типа в нем нажимаешь клавишу, и соотв символ должен высветиться на MSX.

Мож какая-н микросхема померла? Или что-то с сетевым блоком MSX? Кстати, в нем есть переключатели. Вполне возможно, надо выставить какое-н значение. На страничке написано что значение не должно быть равно 0 (не учительская). Может заработает?

Это какие установки а гипертерме позволяют передавать символы на экран MSX?

Por cax

Prophet (3735)

imagem de cax

28-11-2009, 11:35

Всё, что приходит в голову - это
- проверить, что сеть включена, или лучше даже переинициализировать её (_NETE:_NETI)
- посылать HELLO.PKT много раз подряд - иногда пакеты пропадают (да-да, стандартная сетевая поддержка в Бейсике временами глюковала)

- попытаться слать файлы через BSEND.BAT
Если это не пашет - скорее всего ошибка в схеме или неизвестная науке трабла с COM-портом.

Кстати, если оно заработает через обычный COM-порт, было бы интересно узнать как оно дружит с переходниками USB-COM.

И самое главное: не сдаваться. Спроси Тима сколько мейлов он получил от меня прежде чем MSXLink заработал Smile

Por AlexBel

Champion (268)

imagem de AlexBel

28-11-2009, 13:10

Попробую поиграться с сетью, переинициализировать.
При попытке отослать через bsend.bat появляется сообщение о том. что пинг не прошел.
Конечно, в схеме может быть ошибка, но при подаче питания на оптрон импульсы есть на выходе. Я потому и написал - может, в схеме указана неправильная распайка кабеля или другие ошибки, мало ли. Все мы человеки Smile

Por cax

Prophet (3735)

imagem de cax

28-11-2009, 17:49

Подумал ещё может заглушку поставить (1<->4, 3<->5) ... мало ли...
Ну и, как выше писали, попробуй поменять выходы 4 и 5, или номер машины проверь, чтоб не 0 была.

Por AlexBel

Champion (268)

imagem de AlexBel

30-11-2009, 19:02

Я пробовал и с заглушкой и без - результат один и тот же Sad
А в плане мейлов Тиму интерсно не их количество, а содержание Smile Можешь вкратце описать возникшие при запуске MSXlink проблемы и их решение, чтобы не дергать лишний раз Тима и не наступать на грабли?

Por cax

Prophet (3735)

imagem de cax

05-12-2009, 17:01

Ты успешно прошёл все известные мне грабли, и всё, что я знаю - я уже рассказал.
Пожалуй, проверь ещё, что получаешь на выходе 5 вольт или около того.
И обязательно сообщи, когда решишь проблему.

Por AlexBel

Champion (268)

imagem de AlexBel

06-12-2009, 18:41

Пока что я линк отложил, займусь попозже, когда закончу и сдам текущий проект. Про фотографии сетевого модуля и модуля с ПЗУшкой помню. но неисправен фотоаппарат, а телефоном фоткать - качество будет плохое. Если удасться найти фотоаппарат - сразу сделаю.

Página 2/5
1 | | 3 | 4 | 5