DotAttack by NOP

Pagina 4/5
1 | 2 | 3 | | 5

Van SjaaQ

Master (215)

afbeelding van SjaaQ

24-03-2020, 07:53

Thanks Manuel. Should not cause it to crash anyway. Everything is done within 1 frame. Faster Z80 just makes it run more in idle (halt).

Van Manuel

Ascended (18125)

afbeelding van Manuel

24-03-2020, 14:25

Can the game handle the situation that processing takes longer than 1 frame? Note that the turboR interrupt routine is quite heavy (but not sure whether you still call it).

Van Wlcracks

Champion (438)

afbeelding van Wlcracks

24-03-2020, 16:29

the game runs in IM2.

Van SjaaQ

Master (215)

afbeelding van SjaaQ

24-03-2020, 19:56

If it would take more than an interrupt, there will be some flickering at the top of the screen. The only time this might occur is when the score is display (or the game over text).

I've run it on a emulated Turbo-R at full speed for some time, but did not experience crashes.

I wonder if somebody else can do testing on real hardware. Could be this particular Turbo-R has some hardware problem.

Van carlosemandrade

Rookie (22)

afbeelding van carlosemandrade

25-03-2020, 01:21

In 60Hz i experience this flickering at top of screen during PSG selection in main menu, in 50 Hz no flicker and no crashes during gameplay.

Van SjaaQ

Master (215)

afbeelding van SjaaQ

25-03-2020, 10:19

Is this flickering occuring when running from EPROM, Megaflashrom or from ram with Sofarun?

Van SjaaQ

Master (215)

afbeelding van SjaaQ

25-03-2020, 10:33

See: https://youtu.be/Ho87PbmYNis

This is openMSX running a GT, which shows timing by changing the border color:
yellow: idle
green: game logic/drawing
red: music/sfx
purple: screen buffer dump

There is no way flickering should occur. I have more than enough "idle" time. I am guessing you are running from a slow rom somehow and it messes with timing of the Turbo-R.

Since it is not reproducible on OpenMSX, there is nothing I can do. I can send you the debug version, maybe you can make a video of the timing?

Van Sylvester

Hero (536)

afbeelding van Sylvester

25-03-2020, 19:37

I did some tests on my TR ST with a GR8NET and SofaRun, and it detects the ROM as Linear. But after starting it I see the nop logo in the top of the screen and it resets. This was in Z80 mode, when I run it in R800 ROM mode, the game works but i'm missing the top of the screen (let say first 40 lines), it's just black (intro) or yellow (in the game). This was with 60Hz, with 50Hz game still resets in Z80 mode, but in R800 ROM mode it works and also the top of the screen is working.

Van SjaaQ

Master (215)

afbeelding van SjaaQ

25-03-2020, 20:14

Did some testing with OpenMSX and sofarun (ram mode):

Turbo-R in Z80 mode: https://ibb.co/4JkzGkg
Turbo-R in R800 mode: https://ibb.co/vkkWBxb

Seems the R800 mode slows down VRAM write with factor 2-3?

Van Grauw

Ascended (10055)

afbeelding van Grauw

25-03-2020, 20:27

Yes the turboR has a heavy penalty on VDP access in R800 mode. It enforces I/O to ports 98H-9BH to be spaced 54 cycles (@ 7.16 MHz) apart by inserting waits. This seems a bit more than strictly necessary; I guess they had their reasons. The wait is adaptive; if you do something else between the I/O, the wait is reduced accordingly, so use that to your benefit.

Pagina 4/5
1 | 2 | 3 | | 5