RAM tester for Moonsound/Wozblaster

Pagina 4/7
1 | 2 | 3 | | 5 | 6 | 7

Van Wolverine_nl

Paragon (1149)

afbeelding van Wolverine_nl

01-11-2018, 10:27

thanks for this Alexey Big smile

Van storhemulen

Supporter (8)

afbeelding van storhemulen

01-11-2018, 10:40

Alexey: The board with 2 SRAMs checks OK with the test utility. The other board with the crackling sound have no SRAM yet. I just tested it with Sonyc and there is sound, but with noise.

Van Alexey

Guardian (3092)

afbeelding van Alexey

01-11-2018, 12:37

I am not an expert, but if you have no SRAM and the game/demo uses samples, then your sound should be somewhat distorted. Please do me a favor - run the test utility on a cartridge that doesn't have SRAM and share the screenshot, thanks. You should have all 'X' in the test...

Van Alexey

Guardian (3092)

afbeelding van Alexey

01-11-2018, 17:22

Thanks. Detection seems to work fine. Smile

Van storhemulen

Supporter (8)

afbeelding van storhemulen

01-11-2018, 19:17

I just built a third board from my third and last YMF278 chip. No crackling sound with this board when running Sonyc, without any SRAM chips installed.

Conclusion: There must be something wrong with board #2, perhaps opamps or YMF278 or some bad soldering.

Van hardwaremaker

Master (238)

afbeelding van hardwaremaker

02-11-2018, 00:44

I have the Tecnobytes OPL4 ShockWave 2, with 2MB of ram, but the utility detects only 1MB.

Van Pablibiris

Paragon (1804)

afbeelding van Pablibiris

02-11-2018, 20:41

hardwaremaker wrote:

I have the Tecnobytes OPL4 ShockWave 2, with 2MB of ram, but the utility detects only 1MB.

Here the same problem. The utility only shows 1MB instead 2MB in my OPL4 clone

Van Alexey

Guardian (3092)

afbeelding van Alexey

02-11-2018, 22:13

According to the source code the program should be able to detect 2MB. I can share the source code in Z80 Assembler if someone wants to take a look. But be warned - the comments are in Russian. Wink

Van Pencioner

Scribe (1398)

afbeelding van Pencioner

03-11-2018, 00:08

It shows also 1Mb RAM with DalSoRI r2 which has 2Mb RAM, just checked

Pagina 4/7
1 | 2 | 3 | | 5 | 6 | 7