Turbo-R Keyboard Problem may not be the Keyboardfilm :(

Door CrazyBoss

Master (209)

afbeelding van CrazyBoss

29-06-2013, 17:08

Hello.

I tried to dig out my Turbo-R (A1ST) from the Basement, I left it there 3-5 years ago, i guess with a keyboard problem. I got "new" spares keyboard film, and it looks good so I am not sure it the keyboard film problem.

Dead keys are: Q R O P L K N M

And spacekey (and Joystick port #1 Fire1) goes on and off. So it may be a ic problem. I didn check, but I am almost sure all components in the turbo-R is smd Sad so it might be hard to find the problem and to change the IC i guess Sad

Anyone have experience with this problem?

if its the keyboard film i could try to make a wire from the keyboard connector to check if i can get the letters missing above. If not it have to be more complicated. I remember there was a brazil guy or something could make new keyboard films, with better quality than the ones used in the turbo-r.

CLAUS - Sweden/Denmark.

Aangemeld of registreer om reacties te plaatsen

Van NYYRIKKI

Enlighted (5900)

afbeelding van NYYRIKKI

29-06-2013, 19:56

Seems that you have auto fire on... (Turn the slider on top of computer all the way left)

Also some connection problem on line 4 coming from keyboard... Check the keyboard connector first... This is most propably just bad connection in the connector.

Van CrazyBoss

Master (209)

afbeelding van CrazyBoss

29-06-2013, 20:22

thanks, but the top is not on at all, actually i could now find it maybe lost when moving around Sad I found out either the keyboardfilm have a loose connection or its the connector cause by pull a bit in the film in the connector i got the missing letters work again. I have a top from a fs-a1wx but the connectors are not the same Sad

i tried to make the film a bit thicker with some tape on the backside, but didn work, so it might be the film after all, but the good news is not a hardware failure.

So can any one confim autofire is on when the top is not connected to the mainboard?

Claus - Sweden/Denmark.

Van CrazyBoss

Master (209)

afbeelding van CrazyBoss

30-06-2013, 11:45

all keys works, had to add a bit of tape on the film to make it thicker.

still problems with space key Sad

i did play one level of palamedes and then space stopped working again.

also an issue with disk drive which is a 3.5" 1.44 drive, it can load, but if i save, basic report "ok", but the files are not saved to the disk. Format also impossible. Maybe the write write from the ribbon cable. something bad?

the computer hang booting if no disk in drive too..

Van jltursan

Prophet (2582)

afbeelding van jltursan

30-06-2013, 12:51

Quote:

So can any one confim autofire is on when the top is not connected to the mainboard?

Yes, if you don't connect the correct set of cables, ren-sha turbo is active. The space must work tho, try to keep it pressed, from time to time it must generate a blank.

Quote:

the computer hang booting if no disk in drive too..

RDY signal problem, try to replace it with an already adapted one (at least RDY signal and DS0/DS1, don't remember about the rest)