MSX Monitor question

Door Samor

Prophet (2106)

afbeelding van Samor

29-07-2005, 09:11

My MSX monitor has started to produce a lot of noise lately, a static sound, it's becoming more and more now. I've had it before but then it suddenly stopped doing that and worked normally for 3 more years.
Does anyone here know what I'm talking about and can tell me what this is ?

Aangemeld of registreer om reacties te plaatsen

Van ro

Scribe (4542)

afbeelding van ro

29-07-2005, 10:41

sound like you need to re-solder some prints, had that same prob on almost every monitor I ever owned.

Van flyguille

Prophet (3028)

afbeelding van flyguille

29-07-2005, 12:18

static noice???

it is like... a HIGH VOLTAGE escape? that sounds like a blow of electricity. If that is true in days with a lot of humidity it sounds worst!

Van Meits

Scribe (6461)

afbeelding van Meits

29-07-2005, 14:05

Had it as well... I still own the same monitor and it's not being repared... It happened to be dust in the high voltage part... Blew it away...

Van SKiLLa

Expert (97)

afbeelding van SKiLLa

30-07-2005, 16:14

Yes, you might try & clean it - vacuumcleaner perhaps ?
I've had it too sometimes, and even a good hit to the side of monitor could help.
If it only gets worse you'd better let an expert (like Repair-Bas) look at it ...

Van Samor

Prophet (2106)

afbeelding van Samor

30-07-2005, 20:09

thanks. I will try.
By the way, the speaker sound recently also became distorted, but it's not all the time. I don't know if it's related (either way I use a stereo set for sound rather than the monitor output anyway)...