20th anniversary demo

Pagina 1/2
| 2

Door Ivan

Ascended (9295)

afbeelding van Ivan

15-10-2004, 00:12

Does it run on turboRs?

I've tried it in my a1gt with CF card (DOS2) and it freezes in the "Abyss productions" logo.

Aangemeld of registreer om reacties te plaatsen

Van DarQ

Paragon (1038)

afbeelding van DarQ

15-10-2004, 00:36

hmmm, the bounce demo Sphere also quits doing anything after the logo has dissappeard when using turboR emulation in openmsx.

oh, the intro of xak ToG is incredible f#$ked up when using turboR emulation with openmsx... don't know if its the turboR or openmsx.

i dont know if i can run that demo with turboR emulation... i should try once

Van Sonic_aka_T

Enlighted (4130)

afbeelding van Sonic_aka_T

15-10-2004, 00:52

It's prolly the way you use the Turbo-R in openMSX. Unless ofcourse you have an older version. Both work fine on openMSX tho, tested them myself...

Van [D-Tail]

Ascended (8247)

afbeelding van [D-Tail]

15-10-2004, 01:10

20th anniversary demo works on MSX turboR. But be aware: it needs 512kB to run! So if you've DOS2 enabled, you won't have 512kB left. Try running in DOS1 mode instead.

Van FiXato

Scribe (1707)

afbeelding van FiXato

15-10-2004, 02:12

hmmm, the bounce demo Sphere also quits doing anything after the logo has dissappeard when using turboR emulation in openmsx.

after the logo disappeared and the disk stops reading, you have to insert disk 2 in it and then press any key. it is mentioned in the topic..

Van wolf_

Ambassador_ (9884)

afbeelding van wolf_

15-10-2004, 02:27

and if you're able to read black on black, it's also mentioned on the screen ^_^

Van DarQ

Paragon (1038)

afbeelding van DarQ

15-10-2004, 08:28

hmmm... i didnt do any reading Big smile just pushed the dsk in the virtual drive! msx style, not reading, but doing!

Van BiFi

Enlighted (4348)

afbeelding van BiFi

15-10-2004, 09:05

Rest assured, we're working on those minor issues. Smile

Van Manuel

Ascended (18083)

afbeelding van Manuel

15-10-2004, 19:43

oh, the intro of xak ToG is incredible f#$ked up when using turboR emulation with openmsx... don't know if its the turboR or openmsx.

It's caused by the missing FDC timing of the TC8566AF emulation in openMSX... Known problem.

Van dvik

Prophet (2200)

afbeelding van dvik

15-10-2004, 21:23

You see the same graphical problems when running the Raytrace demo (I think by the guys that made the Swiss demo) in TR mode.

The strange thing is that it works fine in the MSX2+ machines that also uses the TC8566AF fdc.

Btw, blueMSX gets similar results in TR mode but the TC8566AF in blueMSX also lacks correct timing.

Have anyone done more research on this to verify that it actually is the fdc timing that causes these problems?

Van dvik

Prophet (2200)

afbeelding van dvik

15-10-2004, 23:16

Ok, I've done some testing and it is the FDC timing that is the problem.

Manuel: I'll send you my updated version of the TC8566AF emulation in blueMSX. I only added support for the data transfer timing but it is enough to make XAK work. I know that it may be a little bit too late to add to 0.5.0 but it would be great if you tested it and added it if it turns out to work ok.

Pagina 1/2
| 2