Nowind, Mac and Linux

Pagina 1/7
| 2 | 3 | 4 | 5 | 6

Door Marq

Champion (387)

afbeelding van Marq

23-05-2011, 21:36

At least back in the day there was supposedly some support for Mac and Linux, but now that I finally got my Nowind, there's software & instructions only for Windows. Oh well, next I downloaded the Nowind libraries from this page: http://code.google.com/p/nowindlibraries/ and tried to compile them on Linux. After a rather tedious process of installing Boost, libusb-dev, cmake etc. the compilation finally started, only to die a few seconds later. Has anyone ever gotten the device to work on Mac or Linux, or is it just an urban legend?

Aangemeld of registreer om reacties te plaatsen

Van Marq

Champion (387)

afbeelding van Marq

23-05-2011, 22:37

In addition: my Canon V-20 and Toshiba HX-10 don't seem to do anything with the module installed, but on the website it says MSX1 compatible. Any success with this?

Van hap

Paragon (2039)

afbeelding van hap

23-05-2011, 23:38

It works fine on my canon v20.
You tried the secondary cartridge slot?

Van Marq

Champion (387)

afbeelding van Marq

23-05-2011, 23:42

The one on the top, don't remember which one it is.

Van Daemos

Paragon (1955)

afbeelding van Daemos

23-05-2011, 23:59

What kind of error do you get when trying to compile?

Van Edwin

Paragon (1182)

afbeelding van Edwin

24-05-2011, 00:05

I did eventually manage to get it to work. It turned out I needed to add special permission in Linux to get nwhostapp to run (or run it as root). Maybe that's the problem for you as well.

Van Daemos

Paragon (1955)

afbeelding van Daemos

24-05-2011, 00:20

If this module loads as a driver it will definetly require you to run it as super user. Also if it installs itself in any of the library directories you will need superuser rights as well.

It is though not normal to get compile errors when compiling as a normal user. Does it directly install on build?

Van Marq

Champion (387)

afbeelding van Marq

24-05-2011, 00:28

I got it to compile (but wouldn't expect Joe Average to be able to do the same), after which nothing happens. Nowind sort of works with my MSX2, but it just says something about host timeout every time, and the Linux PC does notice that there's a new device, but doesn't do much with it. I have the required permissions for the device file. Tried two different cables already, too. I'm using the libusb + kernel version, not the vendor driver.

Van Edwin

Paragon (1182)

afbeelding van Edwin

24-05-2011, 00:36

I don't think I ever got the libusb version to work. With libftdi it does work. As for permissions, in Ubuntu I had to add a special udev rule for permission as user.

Van yzi

Champion (444)

afbeelding van yzi

24-05-2011, 16:46

Van Manuel

Ascended (18254)

afbeelding van Manuel

24-05-2011, 23:21

Nowind works fine on my MSX machines under Linux, using libusb.

yzi: the sf.net project is dead, use the google code one. They moved to GOogle at some point.

Pagina 1/7
| 2 | 3 | 4 | 5 | 6