Oh no... analogic board malfunction.

Door hardheavy

Resident (52)

afbeelding van hardheavy

11-05-2011, 20:35

My MSX , model Expert DD PLUS has a problem (another). The music and sound is ok on tv, but the small speaker is mute. I checked the speaker individually and its ok, so i presume the problem is on the analog board. I dissasemebled it and found out a bit bloated 6800uF capacitor. It´s a little bit, almost plane. Could this be a symptom?. I just cleaned the volume button, but no results.
What may be causing this problem?
Remember in TV( i use a RCA cable ) the sound is perfect.

thank you for your patience!.

Aangemeld of registreer om reacties te plaatsen

Van Daemos

Paragon (1958)

afbeelding van Daemos

12-05-2011, 09:08

Ok. Need more info on this one. You have a onboard speaker? How did you test the speaker?

If the awnsers to these questions are yes, I hear sound comming out of that speaker when I hook it up to a audio source then:

Grab a scope and start probing at the speaker connector with the MSX giving a continues sound output. See what you will find there. Then trace the signal path (yes that is a terrible thing to do but I believe the problem is small.) until you start finding sound waves. Sounds like a broken output buffer which is usually a 2sc536F which you can replace with a BC548. you will then see 0 amplification behind the buffer. If its a broken cap you will most of the time see flatlines with wierd ugly bumps in it or a terribly distorted signal.

No scope or done tracing? Trace the signal path and see which transistors are broken with a DVM and check if the resistors are in good order. Furthermore check the capacitors for damage and if they still charge properly. If any of the components are good then we might suspect a power failure in the end amplifier circuitry and thus check all the transistor collectors power supply.

Van hardheavy

Resident (52)

afbeelding van hardheavy

12-05-2011, 22:23

I ´ve tested the speaker and it is ok. I take it off and put on a small battery handheld radio. Its perfect. Yesterday i select MUTE on TV , so i heard the game sound almost mute coming from speaker.
Today i replaced the suspect capacitor( 6800uf 16V) but the problem remains.
Now i suspect the volume button.
Thank you Daemos!!! you are a very cool dude!

Van hardheavy

Resident (52)

afbeelding van hardheavy

12-05-2011, 22:54

Problem solved. The volume button was damaged. Thank you!