ROMLOAD version 1.99w released

by Jorito on 02-11-2013, 18:29
Topic: Software
Tags: Utilities
Languages:

TNI just released a new version of ROMLOAD, the utility that allows you to load ROM images into special cartridges. This version supports DAC, configurable hotkeys and more. As of version 1.99w, no features will be added. Any feature requests will be considered for ROMLOAD 2 from now on. The last 3 version letters (x, y and z) will be for bugfix releases only.

New in this version:

  • Fixed bug causing a file not found to be (unintended) generation of ROM image too large error
  • Start ROM in SCREEN1 for compatibility
  • Added support for DAC for 2 Konami titles. This is a requirement for Hai No Majutsushi
  • Made the hotkey configurable

Relevant link: ROMLOAD product page

Comments (13)

By KdL

Paragon (1407)

KdL's picture

03-11-2013, 01:46

wow thanks! Smile

By OeiOeiVogeltje

Paragon (1398)

OeiOeiVogeltje's picture

04-11-2013, 16:01

Goed bezig!!!

By Retrofan

Paragon (1262)

Retrofan's picture

12-10-2014, 13:58

Would be nice if we could load more ROM images into the PlaySoniq (for example: 128kB for Game Master 2 and 384kB for Konami games: 3 x 128kB or 1 x 256kB and 1 x 128kB) It's called block parameters with the first version of MegaFlashROM SCC (OPF). This is the only feature I miss right now... But... great ROM loader!

By Louthrax

Prophet (2406)

Louthrax's picture

05-01-2015, 12:29

Hi Bifi,

Thanks for this great tool !

I just have a problem to report : launching ROMs on my TurboR does not work when my SCC cartridge is located in a subslot.

Here's my config :
- TurboR expanded to 512Kb memory.
- MegaFlashROM SCC+ SD in Slot1.
- Modulon slot expander in Slot2, with original Snatcher or SD Snatcher cartridge (not memory expanded) in subslot 0. I tried other subslots too with the same problem.

By Retrofan

Paragon (1262)

Retrofan's picture

05-01-2015, 19:58

@Louthrax: did you also try /R option instead of /S? Or ROMLOAD romfile /S /T:0 /H
Will it work this way? It worked for me.

Probably there's a little bug with /S parameter in subslot. BiFi will investigate this problem as I also discovered this issue with ESE-SCC in combination with MK slotexpander. (ESE-SCC works fine in MK slotexpander, but only in subslot 3). In primary slot there's no problem with /S option.

Also, is the amount of memory detected when you inserted Snatcher Sound Cartridge in subslot 0 of Modulon when you execute ROMLOAD without parameters?

By Louthrax

Prophet (2406)

Louthrax's picture

07-01-2015, 00:59

Thanks Retrofan. I tried lots of things :
- Launching with /S /T:0 /H
- Launching with /R
- Put SCC cartridge in Modulon subslot 3.
with the same result (MSX freezes).

Also, I've found a strange thing : if I change CPU mode to Z80 ("cpu 0" on the command line), and type ROMLOAD, the cartridge is not detected. Type cpu 1 and ROMLOAD again, the cartridge is detected.

I see no memory indication about the memory when launching without parameters (I have version 1.99w, is that the latest one ?).

By Retrofan

Paragon (1262)

Retrofan's picture

07-01-2015, 07:56

Hi Loutrax: do other cartridges work fine in all subslots?
Subslot 0 was defective with my Modulon which is now in repair.
I remember the amount of memory was detected with my Snatcher Sound Cartridge (expanded to 128kB). When I got the Modulon again, I will do some more tests.
I have the same configuration as you (Turbo-R ST, 512kB internal, MFR SCC+ SD 512kB)

By Louthrax

Prophet (2406)

Louthrax's picture

08-01-2015, 18:35

Yes, everything seems to work with normal game cartridges in my Modulon !

By Retrofan

Paragon (1262)

Retrofan's picture

11-01-2015, 16:47

@Louthrax: try version 1.99s It works fine now in Modulon! So, it's a bug in the newest ROMLOAD! Anyway, I only got it work with King's Valley 2 right now... (?)

By Retrofan

Paragon (1262)

Retrofan's picture

14-01-2015, 12:28

@Louthrax: sent you some mail... Wink

By Louthrax

Prophet (2406)

Louthrax's picture

15-01-2015, 23:40

Retrofan wrote:

@Louthrax: try version 1.99s It works fine now in Modulon! So, it's a bug in the newest ROMLOAD! Anyway, I only got it work with King's Valley 2 right now... (?)

I confirm version 1.99s works fine with /S option! /R option hangs the MSX after the "MegaFlashROM SCC+ SD..." boot message has been displayed.

By toughkidCST

Rookie (19)

toughkidCST's picture

18-06-2015, 09:29

Quote:

Here's my config :
- TurboR expanded to 512Kb memory.
- MegaFlashROM SCC+ SD in Slot1.
- Modulon slot expander in Slot2, with original Snatcher or SD Snatcher cartridge (not memory expanded) in subslot 0. I tried other subslots too with the same problem.

I have a question.
I've heard that megaflash scc+ sd has scc-i function.
Why do you need another scc+ (sd snatcher cartridge) in subslot same time?

By Metalion

Paragon (1428)

Metalion's picture

01-06-2016, 21:35

I can't get the Hotkey to work.
Each time I configure it, when the MSX boots and I press it, it resets ...