SofaRun, execrom and SDMMR 1024K help needed

ページ 1/2
| 2

By Druuna333

Supporter (16)

Druuna333 さんの画像

17-02-2022, 18:07

Hello,
I'm an MSX newbie :-)
I'm trying to install an SDMMR 1024K for my MSX 2 64K, the Nextor boots fine and I can reach the A: prompt (most of the times) but when I execute the "sr" or "sr /S" command the computer freezes. Any suggestion?

I can see that I could load roms as well with execrom but how do I boot in dos 1.5
and how do I use execrom? with rom files is ok?
https://www.youtube.com/watch?v=WzV5xIYEZtM

I found a page for execrom but is full of beautiful japanese girls but no info about execrom LOL

ログイン/登録して投稿

By Manuel

Ascended (18781)

Manuel さんの画像

17-02-2022, 21:21

ExecROM is (for larger ROMs) only usable with a MegaRAM cartridge.
Better try SofaROM (SROM.COM, I believe), which is coming with SR.

Which MSX2 are you using exactly?
And what is exactly a SDMMR 1024k? What are the specs? Is there a link to the shop/manufacturer?

By Parn

Paladin (781)

Parn さんの画像

17-02-2022, 21:59

The SDMMR 1024k is a combo cartridge with an SD card interface and 1024kB RAM. Its RAM can be fully used as memory mapper, MegaRAM or equally divided between both. See here:

Fabrication d'une cartouche SDMMR 1024k (in French)

By Druuna333

Supporter (16)

Druuna333 さんの画像

17-02-2022, 22:46

I have a Panasonic FS-A1, will try with SROM.COM but its instructions suggest to use SR.
I see users on Youtube loading roms with execrom too but not sure how to boot in msx-dos 1.05, I tried to press "1" ar boot time as per Nextor User Guide but did not work:
https://www.youtube.com/watch?v=WzV5xIYEZtM
http://mymsx2.free.fr/montages/Cartouche_SD_MMR_1024K/cartou...
What is strange is that when I boot in Nextor sometimes the computer becomes unresponsive even just running simple commands like "dir".

By Manuel

Ascended (18781)

Manuel さんの画像

18-02-2022, 00:21

That sounds bad... something is definitely wrong/broken then. Yes, SR is of course much easier, but you could try with SROM if SR isn't working. But if even something like 'dir' is hanging it up, I guess some other thing is causing problems.

By Parn

Paladin (781)

Parn さんの画像

18-02-2022, 01:15

Have you tried a different SD card? Maybe your SDMMR doesn't like the one you're using.

By Druuna333

Supporter (16)

Druuna333 さんの画像

18-02-2022, 10:18

Yes, I tried a new 32Gb one and an old 512Mb one that I usually use with a zx spectrum Retroleum smart card.
I formatted in fat16 both from msx (or linux using gparted) and I can boot fine to Nextor on "a:" drive but as soon as I try to execute commands the msx 2 freezes.
I got even an img image with the card and have the same issue even with the img.
Should I try to boot into msx-dos 1.5 instead of Nextor? But how?
Do I need to add the batteries in the msx? right now the battery slot is empty.

By Parn

Paladin (781)

Parn さんの画像

18-02-2022, 12:42

I personally see no reason to confine yourself to DOS1. Yes, ExecROM is fine but SofaRun would be much friendlier to use. I suggest you try different memory configurations (for example, both mapper and MegaRAM enabled, and only one of them enabled) and see what happens in each case. I don't know if this is possible, but please also try with both mapper and MegaRAM disabled. If in any case DOS doesn't boot, try the FILES command in BASIC to see if at least the card is seen. If you can, also try the cartridge in another MSX.

I wonder if the symptoms you're experiencing could be caused by some kind of version conflict. Perhaps you have a mismatch between the NEXTOR.SYS in your card and your SDMMR's Nextor kernel?

By Druuna333

Supporter (16)

Druuna333 さんの画像

18-02-2022, 14:27

Seems booting fine in DOS1 with mapper and MegaRAM disabled and the system seems more stable.
I can execute execrom and seems working but I can't find the \ backslash key on my FS-A1 keyboard :-(
Wanted to try execrom "a:\ROMS\filename.rom", I suppose that would be the right command?

By Parn

Paladin (781)

Parn さんの画像

18-02-2022, 15:35

Two things: Firt, in Japanese computers, we use ¥ instead of backslash. However, there's no support to subdirectories in DOS1, so everything must be placed in the same folder. Second, I'm starting to suspect the memory chips in your cartridge may be defective. See if you're able to run TESTRAM.COM with your SDMMR in full MegaRAM mode to diagnose its RAM.

By Druuna333

Supporter (16)

Druuna333 さんの画像

18-02-2022, 20:30

I tried a good few times today and seems freezing even trying to run TESTRAM (from Nextor) or EXECROM (both from DOS1 or Nextor).
Even trying simple commands like "DIR" sometimes is freezing (particularly on Nextor).

ページ 1/2
| 2