Casio PV-16 - doesn't start

By Alexey

Guardian (3167)

Alexey さんの画像

02-09-2018, 12:39

Got a pair of Casios (PV-7 and PV-16) from Japan using the Buyee.jp services. Ended up way more expensive than I originally thought. Both machines were problematic. One had a partially broken keyboard (already fixed), the other - PV-16 doesn't start at all.

The CPU frequency, Reset signal and power are OK. The data and address signals on the CPU board are working fine. I found out that the VDP's clock is not working. Desoldered and tested the oscillator separately - it works at its defined frequency. But on-board it doesn't work. Supplying the external 10.7Mhz frequency to the VDP doesn't help. So the VDP (TMS9118NL) is my primary suspect for the failure.

Does anyone have any ideas what could cause the failure?
Does anyone have a spare TMS9118NL chip?
Need to find the service manual or schematics for PV-16. Anyone could post a link here please?

ログイン/登録して投稿

By SearEclair

Supporter (8)

SearEclair さんの画像

04-09-2018, 12:21

Hello.

If the CPU clock output from VDP is fine, it seems that the clock is input to VDP.
If 10.7 MHz is not input to VDP, CPU clock will not be output.
When my PV-7's VDP clock was solder cracked and Not connected, CPU clock was not output.

By Alexey

Guardian (3167)

Alexey さんの画像

04-09-2018, 17:43

I wish I had a schematics... The CPU clock is fine, but I get some weird output on CAS for VRAM. Some other signals are missing or quite noisy. I ordered a new VDP. Let's see if this helps.

By SearEclair

Supporter (8)

SearEclair さんの画像

05-09-2018, 06:37

I hope your PV-16 will be cured by VDP exchanges.

I have also looked up the circuit diagram, but I could not find it.
I have repaired and remodeled many MSX such as PV-7, PV-16, so it would be nice if I could share information.My Twitter

By Alexey

Guardian (3167)

Alexey さんの画像

19-09-2018, 17:29

Changing the VDP didn't solve the problem. Next, I will put VRAM chips in sockets and change them. As there's no schematics, I will have to socket the chips one by one in order to find the problem.

By Alexey

Guardian (3167)

Alexey さんの画像

20-09-2018, 15:25

Socketed the VRAM and resocketed the VDP. Now the machine starts! So I presume the problem was in the VDP and my initial test with the new VDP failed because of some loose pin. I will keep the original VRAM installed. Now the machine is up and running some games. Smile

UPDATE: Also I found out that the keyboard was not working because it was not used for so long time. I disassembled the keyboard and cleaned the membrane. But the down button was still not working on the joypad. It appeared that the edge of the membrane that was inserted into the socket on the mainboard was somewhat shabby. So I had to cut 1-2mm from the edge so that the membrane comes in good contact with the socket pins. Now everything works. :)

By hamlet

Scribe (3631)

hamlet さんの画像

19-09-2018, 21:05

I like those Casios. Great work, Alexey!