RAM tester for Moonsound/Wozblaster

ページ 6/7
1 | 2 | 3 | 4 | 5 | | 7

By Manel46

Hero (647)

Manel46 さんの画像

12-11-2018, 22:37

I do the tests with the program in a folder, in the Micro SD of the MFR.
Executing the cpu change (chgcpu) previously, it detects the 4x512kbs, which the cartridge carries, before only 2x512kbs. I was not sure of the ram of "Del Sol Ri2".
Unfortunately, the next test fails in the 3 attempts per bank.

By Pencioner

Scribe (1508)

Pencioner さんの画像

12-11-2018, 23:48

Manel46 wrote:

it detects the 4x512kbs, which the cartridge carries, before only 2x512kbs. I was not sure of the ram of "Del Sol Ri2".
Unfortunately, the next test fails in the 3 attempts per bank.

DalSoRi has 2048K RAM (i have one in house). do you have any other MSX2(+), not Turbo, to check how it works with it? it is weird...

By Manel46

Hero (647)

Manel46 さんの画像

13-11-2018, 01:12

I have repeated the test, with the same result.
I'll see tomorrow if I connect my MSX2 full of dust Smile , and I test it.

By Manel46

Hero (647)

Manel46 さんの画像

13-11-2018, 11:12

I'm sorry, I did not use "chgcpu" correctly. I did it without a parameter. For Z80 it is "chgcpu 0". The test works perfectly. Also on my MSX2. I do not have 2+.
Good job!

By Manel46

Hero (647)

Manel46 さんの画像

13-11-2018, 11:29

You could add this in your code:

LD A,(2DH)
CP 3 ;Turbo-R?
JR NZ,NOTR
LD A,80H
CALL 180H
NOTR:

By Pencioner

Scribe (1508)

Pencioner さんの画像

13-11-2018, 12:24

i could do that (with small changes, instead of LD A,(2DH) shoudl be interslot read call used etc, because under DOS page 0 is on RAM, not BIOS) but i have no TR to test. i'll fix soon, would you like to help me to test if it works? (and i think switching back to Turbo at the exit is expected too...)

By Manel46

Hero (647)

Manel46 さんの画像

13-11-2018, 12:48

Pencioner wrote:

would you like to help me to test if it works? (and i think switching back to Turbo at the exit is expected too...)

I do not have any experience with DOS, but I intuited what you tell me.
Agree, friend, we test what you want.
Yes, it would be good in the TR, when leaving, recover R800.
My email address is in my profile.

By Manel46

Hero (647)

Manel46 さんの画像

13-11-2018, 16:38

https://www.msx.org/wiki/R800_Programming#R800_mode_.3C.3E_M...
Here you have the routine asm, for DOS, of the cpu change "EASYCPU.COM".

By hardwaremaker

Master (245)

hardwaremaker さんの画像

17-11-2018, 14:18

I tested it on my Tecnobytes OPL4 Shockwave 2, and pass the test well, detecting 2MB.

By thezorry

Resident (63)

thezorry さんの画像

31-01-2021, 01:21

I recently purchased a fm blaster DIY kit from repro factory. I’m having problems getting it 100% working. I’m getting some distorted sounds and I ran moontest to ensure the memory is properly working, getting this result:

I’ve checked my soldering again and again and I’m stuck atm, any ideas on where can be the problem? I's funny that both banks fails the same addresses, so I guess the problem should be some address line not properly soldered (but I rechecked them a lot of times).

Thanks for your help!

ページ 6/7
1 | 2 | 3 | 4 | 5 | | 7