SofaRun v2.0 bug report thread

ページ 37/39
30 | 31 | 32 | 33 | 34 | 35 | 36 | | 38 | 39

By bobrocks95

Supporter (10)

bobrocks95 さんの画像

02-04-2021, 10:39

Unlikely to be a bug but I'm unable to run the save patched versions of Castle and Castle Excellent with Sofarun 8.0 on an SX1Mini+ (One Chip MSX derivative)

I have set the mapper to ASCII8 as the patch notes said, but I just get a teal screen after launching. Oddly if I set the mapper to auto and it picks Linear it will show what looks like the intended boot screen that checks memory and the rom file, and mentions the name of the guy who made the patch. This also appears with the ASCII8 mapper selected and the Memory Mapper as the preferred device, though the launcher text says I only have 16K of ram with that configuration, which isn't enough, then hangs.

Patched rom is an odd 40KB ASCII8 mapper rom, which I'm assuming is not a standard size the auto mapper selection would know about. Other than that the patch notes mention plenty of flash carts it apparently works fine with.

By AxelStone

Prophet (3120)

AxelStone さんの画像

02-04-2021, 11:15

Manuel wrote:
sunn wrote:

I've had Zero luck with Tower of Gazzel and Turbo R St. No matter what options I try. I'm using SofaRun.

I got it running perfectly. On my GT I had to add some disk delay to get the graphics working in the intro demo. What happens on your system?

That's correct, Gazzel needs to add disk delay to execute correctly the opening.

One general question @Louthrax, about ROMs with save game option (using SRAM or writing directly in the flash, like moderm homebrew games), is it possible to implement some kind of feature in SR to save games in SD or this feature should be only possible patching the ROM?

Thanks!

By Colive201

Supporter (13)

Colive201 さんの画像

06-06-2021, 07:18

Having directory not found error on sofarun

By Colive201

Supporter (13)

Colive201 さんの画像

06-06-2021, 07:19

Please I asking your help, I removed some games of my sd card and now the sofarun is showing the message "directory not found" I believe this happens because sofarun start in the last file that was before. Please help me. I cant play my roms in my msx anymore!

By Manuel

Ascended (18864)

Manuel さんの画像

06-06-2021, 10:40

Start up with /I parameter. See the manual Smile

Louthrax: perhaps it would be a good idea to make this a warning and then strip down the path until it is valid?

By gdx

Enlighted (5591)

gdx さんの画像

06-06-2021, 11:58

Otherwise delete the contents of /SETTINGS folder.

By Colive201

Supporter (13)

Colive201 さんの画像

06-06-2021, 11:33

I tried to delete the sofarun folder but didn't work. Please explain how to do the /I parameter and if you could the link for sofarun manual.

By Colive201

Supporter (13)

Colive201 さんの画像

06-06-2021, 14:05

I delete the wrong folder before. I deleted the contents of the settings folder and now is working. Thank you very much ????☺????????

By gdx

Enlighted (5591)

gdx さんの画像

06-06-2021, 15:09

Sorry, I had copied the wrong folder name and re-edited my message too late.

By Manuel

Ascended (18864)

Manuel さんの画像

06-06-2021, 16:06

ページ 37/39
30 | 31 | 32 | 33 | 34 | 35 | 36 | | 38 | 39