Please HELP. Sony HB 701 FD

Page 1/6
| 2 | 3 | 4 | 5 | 6

Par Kostek2005

Rookie (32)

Portrait de Kostek2005

16-05-2021, 17:07

Please help.
Sony HB 701 FD
I have a problem with the sony hb 701fd.
1. After switching on, a pink startup screen appears (I think it should be blue) and asks for the date
2. After switching on and entering the date, it loads straight to basic, although it should load into the HitBit Art program.
-Floppy drive is disconnected because it doesn't work
-I replaced the graphics IC 9928 and it's the same
-After disconnecting the pcb with basic and the fdd driver, the computer loads to HitBit Art but the image is pink all the time
-games run on strange colors
-colors can only be changed in basic when turn on video mode on the front of the computer.
Please help. I don't know where to look
Thanks .

!login ou Inscrivez-vous pour poster

Par bsittler

Master (239)

Portrait de bsittler

16-05-2021, 19:53

Is it possible to share a photograph of the startup screen? Do you use the RGB video output or the RF video output? Is it possible to try the other one, maybe a cable is bad somewhere?

Also what does this BASIC program show?

SCREEN 1:COLOR 15,4,7

Par Kostek2005

Rookie (32)

Portrait de Kostek2005

16-05-2021, 20:05

https://drive.google.com/file/d/1aiL4_AWg986BNie_tyi2h_qp9Ab...
https://drive.google.com/file/d/1ad9qtF-k3oyt-aIm74vjbmsZXHg...
I'm using an AV cable. It's a Japanese computer but it shouldn't be a problem with a modern LCD tv. I have some Japanese consoles and they work fine.
There is very little information about the sony hb 701
Thanks

Par mars2000you

Enlighted (5919)

Portrait de mars2000you

16-05-2021, 20:14

Impossible to see your pictures (access denied) ....

For the infos, check the Wiki: https://www.msx.org/wiki/Sony_HB-701FD

Par mars2000you

Enlighted (5919)

Portrait de mars2000you

16-05-2021, 20:26

The colors are indeed wrong.

Can you also enter CALL HITBIT on the MSX-BASIC screen? Maybe you can access the firmware with this instruction.

Par Kostek2005

Rookie (32)

Portrait de Kostek2005

16-05-2021, 20:42

I tried these commands and it doesn't work, it shows an error.
In this computer the basic disc is on a separate PCB together with the FDD controller. HitBit program is on the motherboard. After disconnecting Pcb with basic and FDD driver, it loads HitBit Art, but with wrong colors.

Par Kostek2005

Rookie (32)

Portrait de Kostek2005

16-05-2021, 20:45

I think there is a problem with pcb with basic and FDD driver, but there is also a graphics problem

Par Kostek2005

Rookie (32)

Portrait de Kostek2005

16-05-2021, 20:59

As I wrote at the beginning, I changed the TMS9928ANL but it did not help.
Where to look?
VRAM?
Capacitors?

Par Manuel

Ascended (17947)

Portrait de Manuel

16-05-2021, 22:09

This is a very cool MSX! I hope you can run some reverse engineering tools on it to be able to emulate it, once you get it back in order.

Par Alexey

Guardian (3121)

Portrait de Alexey

17-05-2021, 02:39

This is quite an interesting and familiar effect. I can observe it on the Sanyo 77 that I tried to fix some time ago. When you command color15,4,4 the effect is gone and the color of the screen becomes natural blue. But after you change the border color to something different than the background color (with the exception of 0 and 1), the strange effect comes back. I suspect that the video decoder chip is either faulty or it is confused by the unstable CSYNC. I was not able to sort out that problem on the Sanyo by adding extra capacitors to the CSYNC signal, so I would be interested to learn if someone finds a solution or at least provides the explanation on why this effect occurs.

Page 1/6
| 2 | 3 | 4 | 5 | 6