MSX Instagr8 - Instagram for MSX1

Page 2/4
1 | | 3 | 4

Par Wlcracks

Champion (430)

Portrait de Wlcracks

01-05-2020, 19:08

cool I don't have social media, very nice, and for the original MSX yeah! awesome

Par glufke

Rookie (31)

Portrait de glufke

01-05-2020, 19:27

Sylvester wrote:

Nice program! any plans to add MSX2/MSX2+ support?

Sure. It's a matter of time to get the MSX2 version ready.

Par ducasp

Champion (371)

Portrait de ducasp

01-05-2020, 20:57

glufke wrote:

Exactly... It's impossible for MSX to deal with:
* HTTPS (for Instagram API)
* JSON parsing (huge files)
* Huge images, conversion to 256x192, conversion to 16 color, conversion to MSX pattern.

All of it it's made in the "middle" layer. (in AWS :-D)
Well, I will update the github in the next days, but if you have a GR8NET, you can download the INSTAGR8.BAS and run in your MSX.

Thanks guys !

Would it be OK if I create a sdcc VERSION of the MSX client for UNAPI?

Par glufke

Rookie (31)

Portrait de glufke

01-05-2020, 21:15

ducasp wrote:

Would it be OK if I create a sdcc VERSION of the MSX client for UNAPI?

Sure!!!

Par x1pepe

Master (142)

Portrait de x1pepe

02-05-2020, 01:36

Very cool.
I'm very impressed man Smile
Do you imagine a Twitter or Facebook version also?

Par FiXato

Scribe (1615)

Portrait de FiXato

02-05-2020, 12:21

8bwitter: Twitter for your 8-bit Wink

Par x1pepe

Master (142)

Portrait de x1pepe

03-05-2020, 10:18

I tryed from a floppy and I get the error:
Direct stament in file 410

Sice a sd works but every time instagr8 give some information the program ends and turn me to basic, its normal?

Par bitsofbas

Resident (53)

Portrait de bitsofbas

05-05-2020, 00:25

Video looks great! But not working here on my NMS8250

"Direct stament in file" ( doesn't say 410, like for x1pepe )

Same behaviour on floppy and SD.

Cheers!

Par ducasp

Champion (371)

Portrait de ducasp

05-05-2020, 13:11

bas.alicante wrote:

Video looks great! But not working here on my NMS8250

"Direct stament in file" ( doesn't say 410, like for x1pepe )

Same behaviour on floppy and SD.

Cheers!

My guess is that glufke's server is not running, I've tried to access it to retrieve files and try to generate a SDCC/UNAPI version of Instagr8 but server was not responding

Par glufke

Rookie (31)

Portrait de glufke

06-05-2020, 19:31

Are you using port 8080 ?
What is the URL you are using to access ?

I just tested right now. It's OK.
And I compared the source that I shared in GITHUB with the one I used to run, and it's the same.
Server never was disabled. That's very weird.

(BTW, I'm working in the MSX2 Screen8 Instagr8) :-D

Page 2/4
1 | | 3 | 4