LOADROM Loads Nothing

Page 2/2
1 |

Par blur2040

Rookie (20)

Portrait de blur2040

27-02-2017, 15:54

Thanks, I'm at work now, but I'll be sure to try one/some of these this evening.

Par blur2040

Rookie (20)

Portrait de blur2040

28-02-2017, 03:49

Well, none of those roms come up as 8kb for me when in msxdox. They all read 16k. Regardless, it seems that Loadrom just doesn't execute on my system. Grumble.

If anyone has any suggestions, I'd appreciate it.

Par Manuel

Ascended (18961)

Portrait de Manuel

28-02-2017, 10:53

Why still use loadrom if you can use SofaROM?

As was pointed out before: it is probably a bug in loadROM with this configuration of 32kB plain RAM and 512kB mapper RAM in another slot. I'll try on openMSX later.

Par Jipe

Paragon (1561)

Portrait de Jipe

28-02-2017, 13:10

for 8k to 48k Roms try ODO
if you boot on MSX DOS you have 64k ram online

Par Manuel

Ascended (18961)

Portrait de Manuel

28-02-2017, 22:17

Which version of loadrom did you try and where did you get it?
I used LoadROM.com v1.0 by trunks. Try some other versions?

Par Victor

Champion (509)

Portrait de Victor

01-03-2017, 14:07

LOADROM just use the RAM Mapper selected as main by MSXDOS...

I don't know exactly your problem.

Par blur2040

Rookie (20)

Portrait de blur2040

01-03-2017, 16:06

To follow up,

1) Again, forgive me, as a MSX neophyte I only recently began to understand that LoadROM (in theory) should be working for me in order to load 128k+ roms. I first thought it just wouldn't work because I didn't have the right hardware. Only after fiddling with the SofaROM beta and reading more about LoadROM did I understand that LoadROM should be working for me (as an alternative), hence me asking. I really hate it when something should work, but it doesn't.

2) I first used the version of LoadROM that came with SofaRun (1.97), but, considering all the failures that I was having, I went back to 1.8? that I found elsewhere online. Same problems as described above.

3) SofaROM -- when I started this thread, Louthrax hadn't released the 1.0 version of it. Yesterday evening, I downloaded the 1.0 and was pleasantly surprised by how well everything was working. I know that most have a MFR or something similar, but I do recommend checking it out. I'll be leaving some bug reports/feedback.

4) Victor - Thank you for popping up. I don't expect you to fix it or anything, but it does appear that hamlet was able to replicate my problem in an emulator (see page #1) albeit with a slightly different configuration. Unfortunately, SD-512 doesn't seem to be emulated, so my setup can't be recreated exactly in emulation. Worse, probably, is that my setup is pretty darn obscure (US CX5M), so that could be another factor in play.

Regardless, I'll be fiddling with SofaROM more as it seems to work pretty well now and obviously, it is super cool of Louthrax to develop it, here in 2017, 30+ years after MSX hit the scence.

Par Manuel

Ascended (18961)

Portrait de Manuel

01-03-2017, 16:24

Still, loadrom should do something for your system. There's nothing that obscure, the point is mosty that it runs with an externa 512kB memory mapper in a 32kB MSX1. What OS are you running? Nextor? MSX-DOS2?

Page 2/2
1 |