MoonBlaster won't start on my CX7/128, any suggestions??

By sdsnatcher73

Paladin (943)

sdsnatcher73's picture

18-08-2019, 20:53

I tried loading the MoonBlaster disk from the Downloads section on my Yamaha CX7/128. I've tried loading it using Rookie Drive NX from attached USB floppy, using disk image and SofaRun as well as extracting files onto MFR SCC+ SD and loading the files from a directory in basic. Either way the MOONBLAS.BAS loads the font but then drops back into basic with Ok.

Oddly enough if I load the disk in openMSX with the same machine and a Panasonic FS-FD1A floppy drive it loads just fine.

What could be happening? Anything I can do to figure this out??

Login or register to post comments

By Manuel

Ascended (16638)

Manuel's picture

18-08-2019, 21:23

Do you have a normal external disk drive to try, just like on openMSX?

By Grauw

Ascended (9067)

Grauw's picture

18-08-2019, 21:38

Maybe you need to keep CTRL key pressed during computer boot to free up a little more memory? Dunno if MoonBlaster was one of those programs (probably not), but worth a try…

By MsxKun

Paladin (935)

MsxKun's picture

18-08-2019, 22:50

If you're using DOS2 try MAP.COM before loading Moonblas.bas

By Meits

Scribe (5858)

Meits's picture

18-08-2019, 22:53

Try Moonblas.ldr

By sdsnatcher73

Paladin (943)

sdsnatcher73's picture

19-08-2019, 10:44

Thanks for the tips, actually there is an issue in the disk image supplied on MRC. I copied all files onto the disk and loaded the program through MOONBLAS.BAS (I left out the AUTOEXEC.BAS file) then I get back to Ok. Today I wrote the DSK to a floppy with FDLOAD and it booted fine, with or without CTRL pressed.

So I had a look at what is in AUTOEXEC.BAS (I suspected it would do some stuff prior to loading MOONBLAS.BAS). But it then seemed to load the whole MoonBlaster program from that basic program. So I loaded MOONBLAS.BAS and compared:

In MOONBLAS.BAS there now appear a _CHDRV and _CHDIR command. Those dirs don't exist on the image and those commands probably don't work in Disk Basic 1.0. So that is why the actual program is not started by the commands that follow.

So I propose that an admin update the disk image in the downloads section. I personally made the following changes:
1. remove the _CHDRV and _CHDIR commands from line 60 in MOONBLAS.BAS
2. Changed AUTOEXEC.BAS to just run MOONBLAS.BAS: