One chip MSX improvement project

Page 61/118
54 | 55 | 56 | 57 | 58 | 59 | 60 | | 62 | 63 | 64 | 65 | 66

By caro

Champion (512)

caro's picture

10-10-2012, 20:07

caro wrote:
vanfanel wrote:

-Eggerland Mistery: strange high-pitch tone in the tittle screen when music plays.

It can be fixed.

I fixed it. Check the new OCM core for the Altera DE1: http://caro.su/msx/ocm_de1.htm

By vanfanel

Champion (446)

vanfanel's picture

10-10-2012, 22:01

@caro: thanks for this new version, but there's something very wrong with this release: it makes some channels inaudible in games, for example Zombie Monsters intro has lost percussion channels: do you know what could be wrong? It is as if you had muted some instruments.

By caro

Champion (512)

caro's picture

11-10-2012, 05:36

vanfanel wrote:

... there's something very wrong with this release: it makes some channels inaudible in games, for example Zombie Monsters intro has lost percussion channels: do you know what could be wrong? It is as if you had muted some instruments.

Specially I did not muted some instruments. I shall check up, why the percussion chanels have disappeared.

By vanfanel

Champion (446)

vanfanel's picture

11-10-2012, 10:45

@caro: maybe you cut off some frequencies that games use when certain percussion channels are sounding? Maybe you filtered them out.

By caro

Champion (512)

caro's picture

11-10-2012, 11:25

vanfanel wrote:

@caro: maybe you cut off some frequencies that games use when certain percussion channels are sounding? Maybe you filtered them out.

Maybe.
Try to listen to sounding, having connected to an output DAC_S on the additional plug DE1 (GPIO1[14]), where the signal with PWM is connected without filtering.

PS. And how about sounding PSG in Eggerland?

By x-nen Aivalahostia

Paragon (1484)

x-nen Aivalahostia's picture

11-10-2012, 11:15

@Caro: thank for this new version, I'll test tomorrow the bug sound on SCC sound aon real carditges is fixed?

By vanfanel

Champion (446)

vanfanel's picture

11-10-2012, 11:41

@CARO: Sorry, I forgot to say! Eggerland strange standing sound IS perfectly fixed, yes!! Smile
I would say that, if we get percussions back, PSG sound would be perfect as far as I can tell!

By legacy

Hero (570)

legacy's picture

12-10-2012, 00:42

Hi all
Is there already a "how to work doc" with MSX on a DE0/DE1 board?

By caro

Champion (512)

caro's picture

13-10-2012, 19:30

Source code and firmware update for OCM on the Altera DE0 board: caro.su/msx/ocm_de0.htm
Fixed PSG and added VGA mode with a frame frequency of 50 Hz (mode PAL).

By vanfanel

Champion (446)

vanfanel's picture

14-10-2012, 21:24

@caro: Thanks for your wrk on the DE0 port! I don't have a DE0 board, only DE1, but I appreciate your efforts to port this wonderfull MSX machine to both boards!

I also tried version 13/10/2012 for Altera DE1, but it's still missing half the drums in this intro:

Zombie Monsters correct intro music
In current versions (13/10/2012) the percussion of this song is missing 1/2 of the drum sounds. I can't record it for now...

Quote:

Try to listen to sounding, having connected to an output DAC_S on the additional plug DE1 (GPIO1[14]), where the signal with PWM is connected without filtering.

Are you saying I can listen to unfiltered signal in pin 14 of the GPIO1 interface of the Altera DE1? Should I connect a jack there? I can't understand it...

Page 61/118
54 | 55 | 56 | 57 | 58 | 59 | 60 | | 62 | 63 | 64 | 65 | 66