One chip MSX improvement project

Page 59/118
52 | 53 | 54 | 55 | 56 | 57 | 58 | | 60 | 61 | 62 | 63 | 64

By vanfanel

Champion (446)

vanfanel's picture

03-10-2012, 15:33

Hi there,

I noticed there are PSG AUDIO problems in some games with the latest 1ChipMSX Altera DE1 version.
I have made some recordings of how wrong some games sound in my Altera DE1. For example:

-Invasion of the Zombie Monsters: strange pitch in main lead with 4th stage PSG audio. Main melody sounds wrong:
Zombie Monsters OCM bad PSG audio
This is how the game should sound in that stage:
Zombie monsters correct PSG audio

-Eggerland Mistery: strange high-pitch tone in the tittle screen when music plays. It remains sounding in the password screen.
Eggerland OCM bad PSG audio
This is how the game should sound:
Eggerland correct PSG audio
As you can see, OCM is also missing the pop-pop-pop sounds when you enter a password character!

It seems a minor problem, so I hope it's easy to fix. Thanks!

By KdL

Paragon (1436)

KdL's picture

06-10-2012, 03:42

Running Naked in a Field of Flowers Running Naked in a Field of Flowers Running Naked in a Field of Flowers

Fitter Status : Successful - Sat Oct 06 03:38:10 2012
Quartus II 64-Bit Version : 12.0 Build 263 08/02/2012 SP 2 SJ Full Version
Revision Name : emsx_top
Top-level Entity Name : emsx_top
Family : Cyclone
Device : EP1C12Q240C8
Timing Models : Final
Total logic elements : 10,966 / 12,060 ( 91 % )
Total pins : 171 / 173 ( 99 % )
Total virtual pins : 0
Total memory bits : 55,232 / 239,616 ( 23 % )
Total PLLs : 1 / 2 ( 50 % )

By vanfanel

Champion (446)

vanfanel's picture

06-10-2012, 13:15

KdL: Is PSG soud fixed in your last release? What I reported is for Altera DE1: I don't have an "original" 1ChipMSX.

By KdL

Paragon (1436)

KdL's picture

06-10-2012, 14:27

I will do all the possible... thx for the report! Smile

Ps. the bad sound links are unavailable.

By vanfanel

Champion (446)

vanfanel's picture

06-10-2012, 16:55

By KdL

Paragon (1436)

KdL's picture

06-10-2012, 19:49

Hi vanfanel, ehm, Eggerland have a good sound with 1chipMSX and OCM-PLD v3.2 Beta 9 firmware.
I know of another bug and I think that yours is a specific problem of Altera DE1 board!

Eggerland PSG Test with OCM-PLD v3.2 Beta 9

By WORP3

Paladin (857)

WORP3's picture

06-10-2012, 20:06

@KDL, do you got the full quartus version ?
I thought that Altera had removed the support for the cyclone 1 fpga ?

By KdL

Paragon (1436)

KdL's picture

07-10-2012, 05:01

Hi WORP3, the Quartus II V12 Full have 30 days trial + the Cyclone support in a separate package.

There are no real differences on final result.
It is useful for parallel compilation and best for analysis of project.
The design assistant show many new warnings and that my knowledges are not again so good!

By vanfanel

Champion (446)

vanfanel's picture

07-10-2012, 14:23

@KdL: You're right, Eggerland sounds well in your core! That's bad news, because that leaves the problem as an Altera DE1 specific problem...
Do both boards share the same exact PSG core? What could be causing this? Maybe different output hardware (capacitors, etc) ?

By KdL

Paragon (1436)

KdL's picture

07-10-2012, 19:09

Yes, PSG core is the same. Check for any external interference (monitor, pc, mixer, etc).

Page 59/118
52 | 53 | 54 | 55 | 56 | 57 | 58 | | 60 | 61 | 62 | 63 | 64