Openmsx no work more after Windows 10 21H1 upgrade.

Page 1/4
| 2 | 3 | 4

By mandoju

Rookie (23)

mandoju's picture

29-05-2021, 17:24

Hi,
I been used Openmsx for many years and everytime works very well, i´ve formated my laptop Dell Vostro from Windows 10 20H2 64 bits for a new 21H1 64bits, clean install. After all drives installed i beggining to tests from all emulators, all worked fine, only the Openmsx 17.0 no worked, the Catapult open the menu perfectily, all machines and extensions all searched and all be fine. I select one MSX type and one ROM, the window open and close one second later. I made test with all version from 15.0 to 17.0 32bits and 64bits all have the same bug. You have a soluction for this error? I love the Openmsx is the best MSX emulator...

Login or register to post comments

By sdsnatcher73

Prophet (2223)

sdsnatcher73's picture

29-05-2021, 18:21

Can you try starting openmsx from a command prompt? Does it then output an error message?

By ren

Paragon (1868)

ren's picture

29-05-2021, 19:21

What language/locale is your Windows in, Portuguese/Brazil perhaps?

By mandoju

Rookie (23)

mandoju's picture

29-05-2021, 21:18

ren wrote:

What language/locale is your Windows in, Portuguese/Brazil perhaps?

Brazilian/Portuguese

By Manuel

Ascended (18129)

Manuel's picture

29-05-2021, 21:46

Yes, please try to run openMSX from the command prompt and see what it displays.

Perhaps there is something with your OpenGL 2.1 support/driver?

By mandoju

Rookie (23)

mandoju's picture

29-05-2021, 21:46

I ram openmsx.exe

In "normal" command prompt "cmd" with adminstrator privileges, the behaviour is the same...
In Powershell with administrator privileges, had this message.

+ CategoryInfo : ObjectNotFound: (openmsx.exe:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException

By mandoju

Rookie (23)

mandoju's picture

30-05-2021, 00:08

Mobile Intel(R) 4 Series Express Chipset with OPENGL 1.1 drivers by Microsoft, the strange is working in Win10 20H2. All another emulator works fine.

By Manuel

Ascended (18129)

Manuel's picture

30-05-2021, 09:43

No messages when run from cmd? What if you run openmsx -v? Does it give you output?

Can you try to edit your settings.xml file in your user folder (in "Documents/openMSX/share" I believe) and add in the settings section:

    <setting id="renderer">SDL</setting>

By gdx

Enlighted (4693)

gdx's picture

30-05-2021, 09:50

Why does OpenMSX 17 need administrator privileges?

By Manuel

Ascended (18129)

Manuel's picture

30-05-2021, 11:39

Nothing changed regarding that.

By mandoju

Rookie (23)

mandoju's picture

30-05-2021, 13:16

Manuel wrote:

No messages when run from cmd? What if you run openmsx -v? Does it give you output?

Can you try to edit your settings.xml file in your user folder (in "Documents/openMSX/share" I believe) and add in the settings section:

    <setting id="renderer">SDL</setting>

D:\Games\MSX\OpenMsx>openmsx -v
openMSX 16.0
flavour: Release
components: GL LASERDISC

Page 1/4
| 2 | 3 | 4