nms8250 adding 2 pc drives.

By spacegremlin

Expert (80)

spacegremlin's picture

13-12-2017, 00:00

i have done this before , but without any problems but now i have this.
first of all i did not had the original rom in it, so i made one. and put it in the msx.
it was the rom for the diskdrive support.

The main thing i did was finally removing the hd switch and did not connect the wire, so the hd switch is always pushed in.
connected the first drive. done all except copy and save.
added the second drive. i also made new flatcables because they are to short afcourse, made them myself.
i also connected 34 to 33. but if correct that is normally not needed with the nms8250 but im not sure.

so all works.

start game from a:
start game form b:
then i wanted to copy from a to b that works.
but when i want to read the disk it says disk i/o error
so i tough lets see what happens when i want to format drive a for DD
then it gave me a error
bad parameter.
Has someone got some info what i am doing wrong, i think it is something simple.

i done the before way in the past, and never had this issue.

i also solder the a drive for selected as drive a.
the second drive i could not find the jumper in a minut, so i tried if it was working as B drive. so i left it like that.

thank you

Login or register to post comments

By spacegremlin

Expert (80)

spacegremlin's picture

13-12-2017, 00:08

i do notice if i leave the only the a drive connected i have this problem.
if i remove the a drive. and connect the b drive on b
i do can format the b drive.

so i think its the drive solder or cable.

i tried the b drive on the a port with the cable from a . and that also works normal.
so it is the solder i think on the a drive.
and both drives i just before without any problems

is it just a simple jumper problem?

By Hans41

Expert (71)

Hans41's picture

13-12-2017, 03:09

If you don't do a thing to your a-drive (no soldering for default a-drive, nothing for disk ready, etc.) and you have not mixed up any connections (you said you made new flat cables), you should only have to connect line 10 to line 12 (on the flat cable). That way, a default b-drive is treated as an a-drive (ds0 signal -> ds1 connection).

But, you do need 33-34 for the disk ready signal back to the controller. Just combine the two lines from controller to drive.
You should do that on both flat cables.

By spacegremlin

Expert (80)

spacegremlin's picture

13-12-2017, 17:06

Yes all done but i am goning to recheck lines 10and12 on the drive.

And done de hd afcourse on both drives.

By spacegremlin

Expert (80)

spacegremlin's picture

13-12-2017, 17:17

But an other think al works but the only the error after saving and format on a

So a is a and b is b. And files a files b works good.
Running disc on a and b also works.

By spacegremlin

Expert (80)

spacegremlin's picture

13-12-2017, 19:53

found the problem the hd switch from both drives do not work the same. changed that. and it is working.