Looking for a memory counter rom (NMS8250)

Page 2/2
1 |

By sdsnatcher73

Paragon (1517)

sdsnatcher73's picture

23-01-2021, 12:24

It may still be some (small) issue with the mapper circuitry then, possibly in the back annotation bits. You can check that with testmap.com I think.

By hansgoos

Supporter (10)

hansgoos's picture

24-01-2021, 12:04

When running testmap.com I see some ' Back annotat. stutter' messages in the beginning (pressing space-bar does continue the test) but in the end the result shows "This mapper is oke" ?

@Alexey: The 'yis503iii_msx2sub_special.rom' ROM isn't working on my NMS8250. With this ROM installed screen stays black and nothing happens. Does this ROM maybe also needs another BIOS ROM?

By Manuel

Ascended (17502)

Manuel's picture

24-01-2021, 15:17

Mapper size: 6 bits, back annotation: 5 bits... that explains perhaps?

By sdsnatcher73

Paragon (1517)

sdsnatcher73's picture

24-01-2021, 15:30

Manuel wrote:

Mapper size: 6 bits, back annotation: 5 bits... that explains perhaps?

Probably that is the reason the BIOS does not detect the full 1024kB.

By Grauw

Ascended (9580)

Grauw's picture

24-01-2021, 15:33

Surely the BIOS does not read the mapper port?

By Manuel

Ascended (17502)

Manuel's picture

24-01-2021, 17:14

If it was a non-official hack on a BIOS it may be possible.

By hansgoos

Supporter (10)

hansgoos's picture

26-01-2021, 08:09

I checked the wiring of the memory upgrade I did (I used the following instructions 1 MB PC-SIMM in NMS 8250/55), and all looks OK.

What would be the most obvious reason I miss an annotation bit? Is that because of bad/wrong wiring, faulty IC or faulty SIMM ?

By sdsnatcher73

Paragon (1517)

sdsnatcher73's picture

26-01-2021, 08:22

So you have 5 bit back annotation which should be 6. schematics indicate you add back annotation on D3, D4 and D5 using the 74LS125. It seems the D5 back annotation, which is bit 6, is not working as expected. So start checking that connection and the 74LS125.

By Alexey

Guardian (2989)

Alexey's picture

26-01-2021, 12:36

hansgoos wrote:

@Alexey: The 'yis503iii_msx2sub_special.rom' ROM isn't working on my NMS8250. With this ROM installed screen stays black and nothing happens. Does this ROM maybe also needs another BIOS ROM?

Sorry, I didn't realize the extent of the messed up ROM layout in NMS 8250. This ROM will not work there.

By hansgoos

Supporter (10)

hansgoos's picture

28-01-2021, 21:37

I found the issue. Pin 4 of IC 74LS125 wasn't connected properly with the IC underneath.

Now TESTMAP shows 6 'back annotation bits', is no longer reporting any errors AND my start screen shows 1024Kb of user RAM Smile

Thank you all for your help!

Page 2/2
1 |