Carnivore2 announcements

Page 14/14
7 | 8 | 9 | 10 | 11 | 12 | 13 |

By Alexey

Guardian (3360)

Alexey's picture

12-05-2022, 22:27

During the final testing of v2.50 release, one of our testers (Wessam) has identified 2 problems with Carnivore2's Boot Menu. As the bugs were not critical, it was decided not to further delay the release and to postpone the bugfixes to a later time.

Bugfixes:
- No music in certain Arabic games when started from Carnivore2's Boot Menu
- Joysticks and joypads no longer work properly in Boot Menu on some MSX machines

The first problem was resolved by adding PSG initialization routine before the control is passed to a game.

The second problem appeared to be very hard to fix. We had to use an alternative music player as the old one somehow affected computers with the real PSG chip and disabled both joysticks. We also had to create the new patch for the player with the special data filter.

Please feel free to download and test the fixed Boot Menu:
https://rbsc.su/files/Carnivore2_v252_Bugfix_001.zip
https://rbsc.su/files/Carnivore2_v252_Bugfix_001.txt

If there are no issues, we will release this version in to the repository.

By Grauw

Ascended (10565)

Grauw's picture

12-05-2022, 22:38

Alexey wrote:

The second problem appeared to be very hard to fix. We had to use an alternative music player as the old one somehow affected computers with the real PSG chip and disabled both joysticks. We also had to create the new patch for the player with the special data filter.

That sounds like the music player was not setting bits 6-7 of PSG register 7 correctly, which controls the PSG’s GPIO port direction. These should always be set to 10xxxyyy.

By tfh

Prophet (3160)

tfh's picture

13-05-2022, 13:05

Thanks. I've update my bootmenu to v2.52 Smile

By emi2

Rookie (17)

emi2's picture

21-05-2022, 13:06

Hello, I want to inform you that my Compact Flash 4Gb. Ver. 2.35 works perfectly with version 2.50
I say this because in the Carnivore2 Compatibility Reference document, it says that it doesn't work with the 2.40 IDE driver v0.1.7 and I also had it working with the previous version.
I can do the necessary tests to ensure its operation, but I don't have any problems, and I have two identical CFs.

Page 14/14
7 | 8 | 9 | 10 | 11 | 12 | 13 |