Define the sprites for SCREEN5 in Assembly for MSX2

Page 2/4
1 | | 3 | 4

By gasparrini

Champion (321)

gasparrini's picture

16-06-2012, 11:35

Hello Guys,

I have still a little problem on multicolor of the sprites in SCREEN5,
because from my programm the multicolor doesn't work!! Unfortunately!!
However I have put $7400 address for multicolor sprites, but it is rights??
Or there is a other problem on this routine assembly ??

I wait your good news....
Best Regards...
AG. ;-)

By DanySoft

Champion (441)

DanySoft's picture

16-06-2012, 21:12

Sorry, Andrea :
For test, please insert FIRST in BASIC the list equ for you SOURCE (as address LD HL, ... to VPOKE ...)
And is OK all line on BASIC, for course, digite the "RUN" .

Terminated, is all OK ? Else
second :check your source assembler if is identic o no from the listing BASIC.
And not found, error or missing line, adding fix this!

Basic is simily as assembleer, but is slow operation (use CALL TURBO to speed)
Bye bye.
DanySoft

By gasparrini

Champion (321)

gasparrini's picture

16-06-2012, 22:20

@ DanySoft,

But I speak Arabic? Or the Japanese? It seems to me that I speak English! Is not it?

If I ask one thing in assembly, and if the source is something wrong ... the help they ask is to solve it in assembly and not in BASIC!

So, please do not give me more give me these answers these tips
how to use the turbo-basic or other tests in basic.

If you do not know how to give an answer to solving the problem, the next time
not respond at all! Ok? =_=

I hope I never have been hard on you!
Regards
AG.

By PingPong

Prophet (3680)

PingPong's picture

17-06-2012, 00:14

gasparrini wrote:

@ DanySoft,
But I speak Arabic? Or the Japanese? It seems to me that I speak English! Is not it?
AG.

If I were you, i would be not so sure of my skills in english

By AuroraMSX

Paragon (1901)

AuroraMSX's picture

17-06-2012, 13:49

gasparrini wrote:

@ DanySoft,

But I speak Arabic? Or the Japanese? It seems to me that I speak English! Is not it?

Actually, to me it seems that you write your posts in italian and then have them mangled by Google Translate. Honestly, your posts are often very hard to understand!

Having said that: DanySofts suggestion is a very good one!First solve the problem in a (programming) language that you can easily understand. Then translate that to assembler.

By PingPong

Prophet (3680)

PingPong's picture

17-06-2012, 15:46

AuroraMSX wrote:

Actually, to me it seems that you write your posts in italian and then have them mangled by Google Translate. Honestly, your posts are often very hard to understand!

I'm from italy. I can assure you that is almost impossibile to understand what this guy is writing. I suspect that a similar problem will arise even if he wrote in plain italian... Google cannot guess what you are thinking

By anonymous

incognito ergo sum (116)

anonymous's picture

17-06-2012, 17:20

gasparrini wrote:

@ DanySoft

Is that a way to treat someone who genuinely tries to help? Sad

By DanySoft

Champion (441)

DanySoft's picture

17-06-2012, 17:31

Sorry, this page is english ? I'm write en english manualy, is Ok ? I'm from Italy. But this page is found only for MSX.
If this text is error, take this google traduttor and send text without error Tongue

Bye bye

By Meits

Scribe (6350)

Meits's picture

17-06-2012, 19:01

Where goes it over Oo

By AuroraMSX

Paragon (1901)

AuroraMSX's picture

17-06-2012, 19:25

PingPong wrote:

Google cannot guess what you are thinking

Not yet, at least Tongue and I sure hope that it will stay like that LOL!

Page 2/4
1 | | 3 | 4