SIDplayer for MSX di NYYR1KK1

Página 6/6
1 | 2 | 3 | 4 | 5 |

Por MäSäXi

Paragon (1884)

Imagen del MäSäXi

22-05-2010, 20:44

Nyyrikki, I just tried to play Finland´s National Anthem "Uuno Turhapuro"´s .SID version on MSX SidPlay. And after few seconds, it suddenly started to play last song I played on MSX SidPlay. Last song played few seconds and after that our national anthem continued again. (nope, it´s not the only one song which does the same, there are several other .SID files which act just the same) I hit the reset and tried again. Again it started to play suddenly previous song (thought now previous song was played second or two less). I pushed POWER ON/OFF and previous song didn´t appear again, but something garbage was played instead in same part of our National Anthem.

I am afraiding you can do nothing for this, but I do really hope that you can make our National Anthem´s .SID version play correct, as our National Anthem "Uuno Turhapuro" plays exactly like it is played from badly scratched CD played in non-working CD-player (=tune forwards and rewinds every now and thenSad). Though that .SID file´s in-game tune plays "correctly" (=as "correctly" as it can play on PSGSmile)

Thanks, if you can do something for it!

hopes MäSäXi

Por enribar

Paragon (1195)

Imagen del enribar

04-08-2015, 00:48

hello sorry for the thread reboot... but there are plans to improve quality of SidPlay?
Atari sounds very good!
https://youtu.be/fyrATuXj8XI

Por Jupp3

Resident (41)

Imagen del Jupp3

04-08-2015, 23:32

Regarding .sid format, for some games there are new rips, and old (less accurate) ones. Perhaps older ones might work better? Trying to find older versions of some "don't work too well" files has been (on low place) on my todo list for quite a while, my MSX isn't in quite working order right now, though, so can't do any tests for now.

F.ex. multispeed tunes don't work at all currently (and no, I wouldn't expect them to work properly either)

Por enribar

Paragon (1195)

Imagen del enribar

04-08-2015, 23:52

tried with robocop 3 soundtrack but very bad results... seems that player cannot render some frequencies or channels

Por NYYRIKKI

Enlighted (5951)

Imagen del NYYRIKKI

05-08-2015, 15:01

The player does not support all timers, but if you have problems with sound quality, please consider replacing your SID-chip. I suspect that it is a hardware problem.

Uuno Turhapuro problem is probably memory address collision... This emulation works in same C64 memory space to keep the emulation speed reasonable.

Por Jupp3

Resident (41)

Imagen del Jupp3

06-08-2015, 13:24

Quote:

please consider replacing your SID-chip.

...and if you do that, please note that 6581 and 8580 operate at different input voltages, changing to the other one might fry the chip!

No idea if you can change the sid type (input voltage) within Playsoniq.

Por enribar

Paragon (1195)

Imagen del enribar

06-08-2015, 16:35

replacing sid chip? I'm not using Playsoniq but a normal MSX1 configuration with PSG, so SID is emulated with SIDplayer (in fact I'm using openMSX for now).
So... Do the waveforms have to be choosen differently?

Por NYYRIKKI

Enlighted (5951)

Imagen del NYYRIKKI

06-08-2015, 18:26

Jupp3 wrote:
Quote:

please consider replacing your SID-chip.

...and if you do that, please note that 6581 and 8580 operate at different input voltages, changing to the other one might fry the chip!

No idea if you can change the sid type (input voltage) within Playsoniq.

There is a dip switch inside that you can use to select the correct model.

enribar wrote:

replacing sid chip? I'm not using Playsoniq but a normal MSX1 configuration with PSG, so SID is emulated with SIDplayer (in fact I'm using openMSX for now).

Oh, then I would definitely call this a major hardware problem. Smile

The SID -> PSG part was not done with a lot of effort. When I made the program I just had only one picture of Playsonic PCB and a PDF-file about how it works... I made this part only to hear some data being played while not having the needed hardware. You can't seriously expect it to sound like SID. These two worlds are too far apart anyway.

Por enribar

Paragon (1195)

Imagen del enribar

06-08-2015, 20:49

oh ok Smile
but listening to the atari player i was wondering if this quality is achievable with msx, too

Por ToriHino

Paladin (793)

Imagen del ToriHino

06-08-2015, 21:01

With an OPL4 it already sounds a bit more like the SID, see http://www.msx.org/forum/msx-talk/development/robosid-player...

Mind you that the Atari uses (almost) the same processor as the C64, where the msx has to emulate both processor and soundchip...

Página 6/6
1 | 2 | 3 | 4 | 5 |