Samurai Shodown unplayble demo on MSX+V9990

Página 6/6
1 | 2 | 3 | 4 | 5 |

Por albs_br

Champion (467)

Imagen del albs_br

30-11-2022, 11:41

New version (0.15.2): now I'm enabling both layers, instead of just B layer.
Layer A is full of clear patterns, so it won't be shown anyway.

When you or someone else could try, here is the ROM:

https://github.com/albs-br/msx-samurai

Thanks

Por ToriHino

Paladin (826)

Imagen del ToriHino

30-11-2022, 19:39

Yes that fixed the problem: video

Looks like you found another difference between the emulator and real hardware.

Por albs_br

Champion (467)

Imagen del albs_br

30-11-2022, 23:19

Great!
Thanks for all help.
I already submitted issues to both openMSX and WebMSX.

Por Manel46

Paladin (674)

Imagen del Manel46

01-12-2022, 10:18

The rom works on WebMSX, but not on OpenMSX.

Por albs_br

Champion (467)

Imagen del albs_br

01-12-2022, 14:15

For me, the current version (0.15.2) works on both emulators:

Por Manel46

Paladin (674)

Imagen del Manel46

01-12-2022, 15:00

Surely I am doing something wrong in the Open. It gets stuck repeating indefinitely "LOADING BG... LOADING SPR,,,"
I have tried with different machines, TR, MSX+ and MSX1, and the same thing happens on all of them. Always forcing ascii16.

Por albs_br

Champion (467)

Imagen del albs_br

01-12-2022, 16:21

Manel46 wrote:

Surely I am doing something wrong in the Open. It gets stuck repeating indefinitely "LOADING BG... LOADING SPR,,,"
I have tried with different machines, TR, MSX+ and MSX1, and the same thing happens on all of them. Always forcing ascii16.

You should enable v9990 and set output to it (or dual video, as I did)

Por albs_br

Champion (467)

Imagen del albs_br

04-12-2022, 23:13

Oh, only now I see it isn't working for you on OpenMSX, the above instructions are for WebMSX.

On openMSX, open the console (F10) and type in the commands:



ext gfx9000

# Switch to normal MSX screen
#set videosource MSX

# Switch to GFX9000 screen
set videosource GFX9000

bind F6 cycle videosource

Comments (lines started by #) aren't necessary

Por pizzapower

Master (151)

Imagen del pizzapower

09-12-2022, 15:00

I recommend you replace gfx9000 by video9000 instead and use Video9000's exclusive superimpose register at 0x6f to make the emulator seamlessly display the screen as if it were a single input.

In my TCL initialization script I write:

ext video9000
set videosource video9000

And I do this to turn V9990 output off:

        ld a, #0x10
        out (#0x6f), a

And this to activate V9990 output when I am ready to display to the screen:

        ld a, #0x18
        out (#0x6f), a

You can put it in a function like I did:

// use Video9000's superimpose control support
void set_ctrl_port(uint8_t byte) __z88dk_fastcall
{
    byte;
    __asm
        ld a, l
        out (#0x6f), a
    __endasm;
}

If you don't want to add support for Video9000 in the final release, you could even use this as a debug mode to ease up development. Wink

Página 6/6
1 | 2 | 3 | 4 | 5 |